Updated: 2022/Sep/29

Please read Privacy Policy. It's for your privacy.


MOUNT_PROCFS(8)             System Manager's Manual            MOUNT_PROCFS(8)

NAME
     mount_procfs - mount the process file system

SYNOPSIS
     mount_procfs [-o options] /proc mount_point

DESCRIPTION
     The mount_procfs command attaches an instance of the process namespace to
     the global filesystem namespace.  The conventional mount point is /proc.
     The directory specified by mount_point is converted to an absolute path
     before use.  This command is normally executed by mount(8) at boot time.

     The options are as follows:

     -o nolinux
             Do not support nodes which are not part of the original procfs
             implementation but have been added for compatibility with the
             Linux procfs namespace.  See FILES for more information.

     The root of the process filesystem contains an entry for each active
     process.  These processes are visible as a directory whose name is the
     process' pid.  In addition, the special entries curproc and self
     reference the current process.  The self symlink appears for
     compatibility with the Linux procfs implementation.

     Each directory contains several files.

     cmdline
             This file is readonly and returns null-terminated strings
             corresponding to the process' command line arguments.  For a
             system or zombie process, this file contains only a string with
             the name of the process.

     cwd     A symbolic link that points to the current working directory of
             the process.  If the target process's current working directory
             is not available or is not at or below the current process's root
             directory, this link will point to "/".

     fd/#    File descriptors which can be accessed through the file system.
             See fd(4) for more information.

     file    A reference to the vnode from which the process text was read.
             This can be used to gain access to the process' symbol table, or
             to start another copy of the process.

     map     A map of the process' virtual memory.  This file comprises lines
             describing the memory regions of the process, where each line
             contains the following fields:

             start-address   The starting address of the region (inclusive).
             end-address     The ending address of the region (exclusive).
             protection      The access permissions for the region,
                             represented as a three-character string using the
                             characters `r', `w' and `x' to denote read,
                             write, and execute permission respectively.  The
                             lack of a permission is represented by a `-'.
             max-protection  The maximum access permissions for the region
                             represented as a three character string using the
                             characters `r', `w' and `x' to denote read,
                             write, and execute permission respectively.  The
                             lack of a permission is represented by a `-'.
             copy-on-write   Whether the region is copy-on-write.  One of:
                             COW   A region that is copy-on-write.
                             NCOW  A region that is not copy-on-write.
             needs-copy      Whether the region needs a copy.  One of:
                             NC   The region needs a copy.
                             NNC  The region does not need a copy.
             inheritance     The inheritance code for the region, as set by
                             minherit(2).
             wired-count     The wired count for the region.  The region can
                             be paged out if its wired count is zero.
             advice          The advice value set by a prior call to
                             madvise(2) for the region.

     maps    A map of the process' virtual memory in a form like the proc
             filesystem as implemented in Linux.  This file comprises lines
             describing the memory regions of the process, where each line
             contains the following fields:

             start-address  The starting address of the region (inclusive).
             end-address    The ending address of the region (exclusive).
             protection     The access permissions for the region, represented
                            as a three-character string using the characters
                            `r', `w' and `x' to denote read, write, and
                            execute permission respectively.  The lack of a
                            permission is represented by a `-'.
             copy-on-write  Whether the region is copy-on-write.  One of:
                            `p'    The region is copy-on-write.
                            `s'    The region is shared.
             offset         The offset into the file being mapped by the
                            region.
             device-id      The major and minor number of the device
                            containing the file being mapped by the region.
             fileid         The inode for the file associated with the region.
             path           The pathname to the file associated with the
                            region.

     mem     The complete virtual memory image of the process.  Only those
             addresses which exist in the process can be accessed.  Writes to
             this file modify the process.  Writes to the text segment
             normally remain private to the process, since the text segment is
             mapped with MAP_PRIVATE; however, this is not guaranteed.

     note    Not implemented.

     notepg  Not implemented.

     regs    Allows read and write access to the process' register set.  This
             file contains a binary data structure struct regs defined in
             <machine/reg.h>.  regs can only be written when the process is
             stopped.

     fpregs  The floating point registers as defined by struct fpregs in
             <machine/reg.h>.  fpregs is only implemented on machines which
             have distinct general purpose and floating point register sets.

     root    A symbolic link that points to the root directory of the process.
             If the target process's root directory is not available or is not
             at or below the current process's root directory, this link will
             point to "/".

     status  The process status.  This file is readonly and returns a single
             line containing multiple space-separated fields as follows:

                command name
                process id
                parent process id
                process group id
                session id
                major,minor of the controlling terminal, or -1,-1 if there is
                 no controlling terminal.
                a list of process flags: ctty if there is a controlling
                 terminal, sldr if the process is a session leader, noflags if
                 neither of the other two flags are set.
                the process start time in seconds and microseconds, comma
                 separated.
                the user time in seconds and microseconds, comma separated.
                the system time in seconds and microseconds, comma separated.
                the wait channel message
                the process credentials consisting of the effective user id
                 and the list of groups (whose first member is the effective
                 group id) all comma separated.

FILES
     /proc/#
     /proc/#/cmdline
     /proc/#/cwd
     /proc/#/exe
     /proc/#/file
     /proc/#/fpregs
     /proc/#/map
     /proc/#/maps
     /proc/#/mem
     /proc/#/note
     /proc/#/notepg
     /proc/#/regs
     /proc/#/root
     /proc/#/status
     /proc/curproc
     /proc/self

     If the linux mount option is used, the following files are also
     available:

     /proc/#/stat
     /proc/cpuinfo
     /proc/devices
     /proc/meminfo
     /proc/mounts
     /proc/uptime

SEE ALSO
     mount(2), sigaction(2), unmount(2)

HISTORY
     The mount_procfs utility first appeared in 4.4BSD.

BUGS
     This filesystem may not be NFS-exported since most of the functionality
     of procfs requires that state be maintained.

NetBSD 10.99                    April 18, 2023                    NetBSD 10.99