Updated: 2022/Sep/29

Please read Privacy Policy. It's for your privacy.


OPERATOR(7)            Miscellaneous Information Manual            OPERATOR(7)

NAME
     operator - C and C++ operator precedence and associativity

DESCRIPTION
           Operator                                        Associativity
           () [] -> .                                      left to right
           ! ~ ++ -- - (type) * & sizeof new delete        right to left
           ->* .*                                          left to right
           * / %                                           left to right
           + -                                             left to right
           << >>                                           left to right
           < <= > >=                                       left to right
           == !=                                           left to right
           &                                               left to right
           ^                                               left to right
           |                                               left to right
           &&                                              left to right
           ||                                              left to right
           ?:                                              right to left
           = += -= *= /= %= <<= >>= &= ^= |= throw         right to left
           ?: (C++, third operand)                         right to left
           ,                                               left to right

FILES
     /usr/share/misc/operator

SEE ALSO
     iso646(3)

NetBSD 10.99                   January 18, 2011                   NetBSD 10.99