I would appreciate any donations. Wishlist or send e-mail type donations to maekawa AT daemon-systems.org.
ADMTEMP(4) Device Drivers Manual ADMTEMP(4) NAME admtemp - Analog Devices ADM1021 temperature sensor SYNOPSIS admtemp* at iic? addr 0x18 DESCRIPTION The admtemp driver provides support for the Analog Devices ADM1021, Analog Devices ADM1023, Analog Devices ADM1032, Genesys Logic GL523SM, Global Mixed-mode Technology G781, Texas Instruments LM84, Maxim 1617, Maxim 1617A, Philips Semiconductors NE1617A, and Xeon embedded temperature sensors. The device possesses internal and external temperature sensors, and programmable low and high temperature limits, with a temperature range of -65 to +127 degC and a resolution of 1 degC. On i386 machines, this driver also supports the Xeon embedded I2C temperature probes. In this case, however, only one temperature value is provided. Exceeding the temperature limits causes the device to assert an Alarm signal, which can be used by other hardware to detect critical conditions. Some sensors differ from the ADM1021, MAX1617 and NE1617A: The ADM1021A, ADM1023, ADM1032, and G781 have a temperature range of 0 to +127 degC and a resolution of 1 degC. The LM84 has no low temperature limits. The ADM1023, ADM1032, and G781 have extended precision remote temperature sensors, with a range of 0 to +127.875 degC and a resolution of 0.125 degC. The ADM1032 and G781 have additional high temperature limits with a range of 0 to +127 degC and a resolution of 1 degC. If these are exceeded, a separate Therm signal is asserted. The sensor and limit values are made available through the envstat(8) interface. For devices without additional high temperature limits, the limits that are displayed and set are the critical limits. For devices with additional high temperature limits, high and low temperature warning limits and high temperature critical limits are displayed and can be set. SEE ALSO iic(4), intro(4), envstat(8) AUTHORS The admtemp driver was written by Theo de Raadt <firstname.lastname@example.org>. Extended precision temperatures, and limit display and setting were added by Julian Coleman <jdc@NetBSD.org>. BUGS Limit sensors occasionally read as 0xff. If this occurs, the admtemp driver will ignore that limit. NetBSD 8.0 December 31, 2015 NetBSD 8.0