I would appreciate any donations. Wishlist or send e-mail type donations to maekawa AT daemon-systems.org.
ALTQ(4) Device Drivers Manual ALTQ(4) NAME altq - alternate queuing framework SYNOPSIS options ALTQ options ALTQ_BLUE options ALTQ_CBQ options ALTQ_CDNR options ALTQ_FIFOQ options ALTQ_FLOWVALVE options ALTQ_HFSC options ALTQ_LOCALQ options ALTQ_PRIQ options ALTQ_RED options ALTQ_RIO options ALTQ_WFQ DESCRIPTION The altq system is a framework which provides several disciplines for queuing outgoing network packets. While traffic shaping is perhaps the most prominent example, altq provides also other measures related to QoS. The framework has been integrated to the pf(4) packet filter since NetBSD 4.0. At the implementation level altq modifies the interface packet queues. Therefore the driver modifications described in altq(9) are required in order to use a certain network card with altq. FILES /dev/altq SEE ALSO pf(4), altq.conf(5), altqd(8), altq(9) Kenjiro Cho, Fitting theory into reality in the ALTQ case, http://www.sonycsl.co.jp/person/kjc/papers/fittingtheory.pdf, Taipei, Taiwan, March, 2004, Asia BSD conference. HISTORY The altq system first appeared in March 1997 and found its home in the KAME project (http://www.kame.net). It was imported into NetBSD 1.6. CAVEATS Please note that you must compile pf(4) in the kernel, using the PF module(7) alongside altq built in the kernel will not work. NetBSD 8.99.34 March 20, 2018 NetBSD 8.99.34