I would appreciate any donations. Wishlist or send e-mail type donations to maekawa AT daemon-systems.org.
ARIA(4) Kernel Interfaces Manual ARIA(4) NAME aria -- Sierra's Aria chipset audio device driver SYNOPSIS aria0 at isa? port 0xPPP irq I aria0 at isa? port 0xPPP irq I flags 1 audio* at audiobus? DESCRIPTION The aria driver provides support for Sierra's Aria chipset, which is the basis of such cards as the Prometheus Aria 16, the Genoa AudioBahn 16 Pro, and some Diamond Sonic Sounds (Rev A5 and Rev B2). The Sierra Aria chipset is full-duplex and is capable of 8- and 16- bit audio sample recording and playback at 7875 Hz, 11025 Hz, 15750 Hz, 22050 Hz, 31500 Hz, and 44100 Hz. Valid I/O addresses are 0x280, 0x290, 0x2A0, and 0x2B0. The IRQ may be set to 10, 11, or 12. The flags setting is necessary for the Prometheus Aria 16, as it needs to be specially configured at each cold boot by twiddling with the joystick port. SEE ALSO audio(4), isa(4) HISTORY The aria device driver appeared in NetBSD 1.4. BUGS DMA is not yet supported. The flags option should not be necessary. It is necessary to configure the port and irq. NetBSD 7.1.2 June 22, 2005 NetBSD 7.1.2