I would appreciate any donations. Wishlist or send e-mail type donations to maekawa AT daemon-systems.org.
AST(4) Kernel Interfaces Manual AST(4) NAME ast -- multiplexing serial communications interface SYNOPSIS ast0 at isa? port 0x1a0 irq 5 com2 at ast? slave ? com3 at ast? slave ? com4 at ast? slave ? com5 at ast? slave ? DESCRIPTION The ast driver provides support for boards that multiplex together up to four EIA RS-232C (CCITT V.28) communications interfaces. Apparently the original maker of hardware using this multiplexing protocol was AST. Each ast device is the master device for up to four com devices. The kernel configuration specifies these com devices as slave devices of the ast device, as shown in the synopsis. The slave ID given for each com device determines which bit in the interrupt multiplexing register is tested to find interrupts for that device. The port specification for the ast device is used to compute the base addresses for the com subdevices and the port for the interrupt multiplexing register. FILES /dev/tty0? SEE ALSO com(4) HISTORY The ast driver was written by Roland McGrath and placed into the public domain. NetBSD 7.1.2 March 30, 1994 NetBSD 7.1.2