I would appreciate any donations. Wishlist or send e-mail type donations to maekawa AT daemon-systems.org.
ATARAID(4) Device Drivers Manual ATARAID(4) NAME ataraid - software BIOS RAID SYNOPSIS pseudo-device ataraid ld* at ataraid? vendtype ? unit ? DESCRIPTION The ataraid driver provides support for BIOS-based software RAID controllers. These are devices which have some simple support for several basic RAID levels (often RAID 0 and RAID 1), but which require software support to actually perform the RAID function. The BIOS support is largely just to create and recognize the array so that it may be a boot device. The driver currently supports RAID formats from: ⊕ Adaptec HostRAID (found in Intel 6300ESB) ⊕ Intel MatrixRAID ⊕ JMicron RAID ⊕ nVidia MediaShield ⊕ Promise FastTrak ⊕ Via V-RAID (found in many VIA-based motherboards) Status of the logical disk, as well as the disks associated with it, can be viewed through the bioctl(8) utility. SEE ALSO ld(4), bioctl(8) HISTORY The ataraid driver first appeared in NetBSD 2.0. AUTHORS The ataraid driver was originally adapted from FreeBSD by Jason Thorpe <thorpej@NetBSD.org>. BUGS Not all features of the software RAID are currently recognized or supported. For example, the Adaptec support doesn't recognize when a RAID 1 should be in a "building" state, and it does not do the right thing. At least part of the reason for this is that the publicly-available information on these formats is quite limited. NetBSD 8.0 September 16, 2008 NetBSD 8.0