I would appreciate any donations. Wishlist or send e-mail type donations to maekawa AT daemon-systems.org.
BOOTPARAMS(5) File Formats Manual BOOTPARAMS(5) NAME bootparams -- boot parameter database SYNOPSIS /etc/bootparams DESCRIPTION The bootparams file specifies the boot parameters that diskless(8) clients may request when booting over the network. Each client supported by this server must have an entry in the bootparams file containing the servers and pathnames for its root, area. It may optionally contain swap, dump, and other entry types. Each line in the file (other than comment lines that begin with a #) specifies the client name followed by the pathnames that the client may request by their logical names. Names are matched in a case-insensitive fashion, and may also be wildcarded using shell-style globbing characters. The components of the line are delimited with blank or tab, and may be continued onto multiple lines with a backslash. For example: dummy root=server:/export/dummy/root \ swap=server:/export/dummy/swap \ dump=server:/export/dummy/swap \ gateway=router:255.255.255.0 When the client named "dummy" requests the pathname for its logical "root" it will be given server ``server'' and pathname ``/export/dummy/root'' as the response to its RPC request. netra[1-5]www* root=server:/export/jumpstart/netra_www When any client with a name matching the pattern "netra[1-5]www*" requests the pathname for its logical "root" it will be given server ``server'' and pathname ``/export/jumpstart/netra_www'' as the response to its RPC request. As this example implies, this is useful for setting up Jumpstart servers for Sun clients. NOTES The server does not default to the localhost, and must be filled in. FILES /etc/bootparams default configuration file SEE ALSO diskless(8), rpc.bootparamd(8) NetBSD 7.1.2 February 28, 2002 NetBSD 7.1.2