I would appreciate any donations. Wishlist or send e-mail type donations to maekawa AT daemon-systems.org.
BT3C(4) Kernel Interfaces Manual BT3C(4) NAME bt3c -- 3Com Bluetooth PC Card driver SYNOPSIS bt3c* at pcmcia? function ? DESCRIPTION The bt3c driver provides support for the 3Com Bluetooth PC Card, model 3CRWB6096, to the Bluetooth protocol stack. FIRMWARE This card needs firmware loaded before it will work. Due to copyright restrictions we cannot distribute the firmware with NetBSD, but if you have the card then you should have received a CD with the drivers on, or you may download the latest version from the 3Com website. Create a directory named bt3c in the search path of the firmload(9) kernel subsystem. Now, extract the driver archive and find the firmware file called BT3CPCC.bin, and place this file in the newly created directory. The firmware will be loaded automatically as needed. DIAGNOSTICS bt3c%d: Cannot open firmware This will be printed to the console if the device cannot open the firmware file as described above. bt3c%d: Antenna In bt3c%d: Antenna Out If the kernel is compiled with the DIAGNOSTIC option, these messages will be produced on the console when the card antenna position is changed. bt3c%d: sleeping bt3c%d: waking up These messages will be produced when the card is enabled or disabled due to power change events. SEE ALSO bluetooth(4), pcmcia(4), firmload(9) HISTORY This bt3c device driver was written by Iain Hibbert using FreeBSD and BlueZ drivers as a reference. It first appeared in NetBSD 4.0. NetBSD 7.1.2 January 14, 2006 NetBSD 7.1.2