I would appreciate any donations. Wishlist or send e-mail type donations to maekawa AT daemon-systems.org.
COMPAT_SUNOS(8) System Manager's Manual COMPAT_SUNOS(8) NAME compat_sunos -- setup procedure for m68k, sparc and sparc64 architectures DESCRIPTION NetBSD/sparc64, NetBSD/sparc and some of the NetBSD/m68k architectures can run SunOS executables. Most executables will work. The exceptions include programs that use the SunOS kvm library, and various system calls, ioctl()'s, or kernel semantics that are difficult to emulate. The number of reasons why a program might fail to work is (thankfully) longer than the number of programs that fail to run. Static executables will normally run without any extra setup. This procedure details the directories and files that must be set up to allow dynamically linked executables to work. The files you need are on your SunOS machine. You need to worry about the legal issues of ensuring that you have a right to use the required files on your machine. On your NetBSD machine, do the following: 1. mkdir -p /emul/sunos/usr/lib /emul/sunos/usr/5lib 2. cp SunOS:/usr/lib/lib*.so.*.* NetBSD:/emul/sunos/usr/lib 3. cp SunOS:/usr/5lib/lib*.so.*.* NetBSD:/emul/sunos/usr/5lib 4. cp SunOS:/usr/lib/ld.so NetBSD:/emul/sunos/usr/lib/ld.so 5. If you ever expect to use YP, you will want to create a link: ln -s /var/run/ypbind.lock /etc/ypbind.lock Alternatively, you can use an NFS mount to accomplish the same effect. On your NetBSD machine, do the following: 1. mkdir -p /emul/sunos/usr 2. mount SunOS:/usr /emul/sunos/usr This will place the SunOS libraries on your NetBSD machine in a location where the SunOS compatibility code will look for first, where they do not conflict with the standard libraries. NOTES When using compat_sunos on NetBSD/sparc64, the COMPAT_NETBSD32 option must also be used. BUGS A list of things which fail to work in compatibility mode should be here. SunOS executables can not handle directory offset cookies > 32 bits. Should such an offset occur, you will see the message ``sunos_getdents: dir offset too large for emulated program''. Currently, this can only happen on NFS mounted filesystems, mounted from servers that return offsets with information in the upper 32 bits. These errors should rarely happen, but can be avoided by mounting this filesystem with offset translation enabled. See the -X option to mount_nfs(8). The -2 option to mount_nfs(8) will also have the desired effect, but is less preferable. The NetBSD/sparc64 support is less complete than the other ports. NetBSD 7.1.2 February 3, 2001 NetBSD 7.1.2