Updated: 2022/Sep/29
Please read Privacy Policy. It's for your privacy.
CPU_DUMPCONF(9) Kernel Developer's Manual CPU_DUMPCONF(9) NAME cpu_dumpconf, cpu_dump, cpu_dumpsize, dumpsys - machine-dependent kernel core dumps SYNOPSIS #include <sys/types.h> #include <sys/systm.h> void cpu_dumpconf(void); int cpu_dump(int (*dump)(dev_t, daddr_t, void *, size_t), daddr_t *blknop); int cpu_dumpsize(void); void dumpsys(void); DESCRIPTION cpu_dumpconf() is the machine-dependent interface invoked during system bootstrap to determine the dump device and initialize machine-dependent kernel core dump state. Internally, cpu_dumpconf() will invoke cpu_dumpsize() to calculate the size of machine-dependent kernel core dump headers. dumpsys() is invoked by cpu_reboot() to dump kernel physical memory onto the dump device. dumpsys() invokes cpu_dump() to write the machine- dependent header to the dump device at block number *blknop using the dump device's PIO dump routine specified by the dump argument. cpu_dumpsize(), cpu_dump(), and dumpsys() are parts of the machine- dependent interface, however they are not exported to machine-independent code. SEE ALSO cpu_reboot(9) NetBSD 10.99 May 24, 2002 NetBSD 10.99