I would appreciate any donations. Wishlist or send e-mail type donations to maekawa AT daemon-systems.org.
ETHERIP(4) Kernel Interfaces Manual ETHERIP(4) NAME etherip -- EtherIP tunneling device SYNOPSIS pseudo-device etherip DESCRIPTION The etherip interface is a tunneling pseudo device for Ethernet frames. It can tunnel Ethernet traffic over IPv4 and IPv6 using the EtherIP protocol specified in RFC 3378. The only difference between an etherip interface and a real Ethernet interface is that there is an IP tunnel instead of a wire. Therefore, to use etherip the administrator must first create the interface and then configure protocol and addresses used for the outer header. This can be done by using ifconfig(8) create and tunnel subcommands, or SIOCIFCREATE and SIOCSLIFPHYADDR ioctls. Packet format Ethernet frames are prepended with a EtherIP header as described by RFC 3378. The resulting EtherIP packets will be encapsulated in an outer packet, which may be either an IPv4 or IPv6 packet, with IP protocol number 97. Ethernet address When a etherip device is created, it is assigned an Ethernet address of the form f2:0b:a5:xx:xx:xx. This address can later be changed through a sysctl node. The sysctl node is net.link.etherip.<iface>. Any string of six colon- separated hexadecimal numbers will be accepted. Reading that node will provide a string representation of the current Ethernet address. Security The EtherIP header of incoming packets is not checked for validity. This is because there seems to be some confusion about how such a header has to look like. For outgoing packets, the header is set up the same way as done in OpenBSD, FreeBSD, and Linux to be compatible with those systems. Converting from previous implementation A tunnel configured for the previous (undocumented) implementation will work with just renaming the device from gif to etherip. SEE ALSO bridge(4), gif(4), inet(4), inet6(4), tap(4), ifconfig(8) HISTORY The etherip device first appeared in NetBSD 4.0, it is based on tap(4), gif(4), and the former gif-based EtherIP implementation ported from OpenBSD. BUGS Probably many. There is lots of code duplication between etherip, tap(4), gif(4), and probably other tunnelling drivers which should be cleaned up. NetBSD 7.1.2 November 23, 2006 NetBSD 7.1.2