I would appreciate any donations. Wishlist or send e-mail type donations to maekawa AT daemon-systems.org.
IPPP(4) Kernel Interfaces Manual IPPP(4) NAME ippp -- ISDN synchronous PPP network driver SYNOPSIS pseudo-device ippp count DESCRIPTION The ippp driver interfaces the IP subsystem of the operating system with the ISDN layer so that a transport of IP packets over an ISDN link is possible. For configuration of the ippp driver, either the ipppctl(8) utility is used or it is configured via isdnd(8) and its associated isdnd.rc(5) file. In case an IP packet for a remote side arrives in the driver and no connection is established yet, the driver communicates with the isdnd(8) daemon to establish a connection. The driver has support for interfacing to the bpf(4) subsystem for using tcpdump(8) with the ippp interfaces. The ipppctl(8) utility is used to configure all aspects of PPP required to connect to a remote site. LINK0 and LINK1 The link0 and link1 flags given as parameters to ifconfig(8) have the following meaning for the ippp devices: link0 Wait passively for connection. The administrative Open event to the Link Control Protocol (LCP) layer will be delayed until after the lower layers signal an Up event (rise of ``carrier''). This can be used by lower layers to support a dial-in connection where the physical layer isn't available immediately at startup, but only after some external event arrives. Receipt of a Down event from the lower layer will not take the interface completely down in this case. link1 Dial-on-demand mode. The administrative Open event to the LCP layer will be delayed until either an outbound network packet arrives, or until the lower layer signals an Up event, indicating an inbound connection. As with passive mode, receipt of a Down event (loss of carrier) will not automatically take the interface down, thus it remains available for further connections. The link0 flag is set to off by default, the link1 flag to on. SEE ALSO bpf(4), isdnd.rc(5), ipppctl(8), isdnd(8), tcpdump(8) AUTHORS The ippp device driver was written by Joerg Wunsch <email@example.com> and then added to ISDN4BSD by Gary Jennejohn <firstname.lastname@example.org>. This man page was written by Hellmuth Michaelis <email@example.com>. NetBSD 7.1.2 August 31, 2000 NetBSD 7.1.2