I would appreciate any donations. Wishlist or send e-mail type donations to maekawa AT daemon-systems.org.
ISDNTEL(4) Kernel Interfaces Manual ISDNTEL(4) NAME isdntel -- ISDN B-channel telephony interface driver SYNOPSIS pseudo-device isdntel count DESCRIPTION The isdntel driver provides an interface to the B-channel for telephony applications and is currently used by the isdnd(8) for answering machine support. The driver is part of the isdn4bsd package. The lower six bits of the driver's minor number are used to specify a unit number, whereas the upper two bits specify a functionality. Functionality zero is the usual telephony data stream i/o driver. Functionality one is used to enable commands to dial out and hang up and receive responses about the state of the dial out progress and status. This commands may change in the future, for details see the file /usr/include/netisdn/i4b_tel_ioctl.h and the isdntel(8) utility. The telephony data stream comes out of the line in a bit-reversed format, so the isdntel driver does the bit-reversion process in any case. Additionally, the user can specify to do A-law to mu-law, mu-law to A-law or no conversion at all in the isdntel driver by using the isdntelctl(8) utility. The driver is able to process several ioctl's: I4B_TEL_GETAUDIOFMT get currently used audio format conversion. I4B_TEL_SETAUDIOFMT set currently used audio format conversion. I4B_TEL_EMPTYINPUTQUEUE clear the input queue. For the I4B_TEL_GETAUDIOFMT and I4B_TEL_SETAUDIOFMT, the following parameters are available: CVT_NONE do no A-law/mu-law audio format conversion. The conversion path looks like this: USER <--> bitreversing <--> ISDN-line CVT_ALAW2ULAW set audio format conversion to do an audio conversion from A-law (on the ISDN line) to mu-law (in the userland). The read(2) conversion path looks like this: USER <-- mu-law/A-law <-- bitreversing <-- ISDN-line and the write(2) conversion path looks like this: USER --> mu-law/A-law --> bitreversing --> ISDN-line CVT_ULAW2ALAW set audio format conversion to do an audio conversion from mu-law (on the ISDN line) to A-law (in the userland). The read(2) conversion path looks like this: USER <-- A-law/mu-law <-- bitreversing <-- ISDN-line and the write(2) conversion path looks like this: USER --> A-law/mu-law --> bitreversing --> ISDN-line SEE ALSO isdnd.rc(5), isdnd(8), isdntel(8), isdntelctl(8) STANDARDS A-law and mu-law are specified in ITU Recommendation G.711. AUTHORS The isdntel device driver and this man page were written by Hellmuth Michaelis <email@example.com>. NetBSD 7.1.2 April 21, 1999 NetBSD 7.1.2