I would appreciate any donations. Wishlist or send e-mail type donations to maekawa AT daemon-systems.org.
LMENV(4) Kernel Interfaces Manual LMENV(4) NAME lmenv -- National Semiconductor LM81, LM87, and compatible hardware monitors SYNOPSIS lmenv0 at iic0 addr 0x2c: ADM9240 rev 2 DESCRIPTION The lmenv driver provides support for the National Semiconductor LM87, National Semiconductor LM81, Analog Devices ADM9240, and Dallas Semiconductor DS1780 iicbus hardware monitors. Sensor values are reported through the envstat(8) interface. The lmenv supports the following voltage, temperature, and fan speed sensors: Sensor Type +2.5Vin Volts DC Vccp1 Volts DC +Vcc Volts DC +5Vin/Vcc Volts DC +12Vin Volts DC Vccp2 Volts DC External Temperature Internal Temperature FAN1 Speed FAN2 Speed On the LM87 monitor, AIN1 and AIN2 Volts DC sensors may replace either, or both of the FAN1 and FAN2 speed sensors, respectively. SEE ALSO envsys(4), envstat(8) HISTORY The lmenv driver first appeared in OpenBSD 3.9. NetBSD support was added in NetBSD 7.0. AUTHORS The lmenv driver was written for OpenBSD by Mark Kettenis <firstname.lastname@example.org>, and ported to NetBSD by Julian Coleman <jdc@NetBSD.org>. BUGS High and low sensor limits are not supported. Interrupt support is not implemented. NetBSD 7.1.2 October 14, 2013 NetBSD 7.1.2