I would appreciate any donations. Wishlist or send e-mail type donations to maekawa AT daemon-systems.org.
LMTEMP(4) Device Drivers Manual LMTEMP(4) NAME lmtemp - National Semiconductor LM75, LM77 and compatible hardware monitors SYNOPSIS lmtemp0 at iic? addr 0x48 flags 0x0000 DESCRIPTION The lmtemp driver provides support for the National Semiconductor LM on iicbus series temperature sensors and register compatible chips. Each device is specified by the value of the address and flags. Device addr flags LM75 0x48 - 0x4f 0x0000 LM75A 0x48 - 0x4f 0x0000 DS75 0x48 - 0x4f 0x0001 LM77 0x48 - 0x4b 0x0002 HARDWARE Chips supported by the lmtemp driver include: Device Range Resolution National Semiconductor LM75 -55 - +125 0.5 degC Texas Instruments LM75A -55 - +125 0.5 degC Dallas Semiconductor DS75 -55 - +125 0.0625 degC National Semiconductor LM77 -55 - +130 0.5 degC The LM75, LM75A, and DS75 have a programmable high temperature limit. When this is exceeded, the device asserts an over-temperature output. The LM77 has programmable low and high temperature limits. Exceeding either of these causes the device to assert an interrupt output. It also has a programmable critical high temperature limit, and exceeding this causes the device to assert a separate critical alarm output. The sensor and limit values are made available through the envstat(8) interface. SEE ALSO envsys(4), envstat(8) HISTORY The lmtemp device appeared in NetBSD 4.0. BUGS Interrupt support is unimplemented. NetBSD 8.0 January 1, 2016 NetBSD 8.0