I would appreciate any donations. Wishlist or send e-mail type donations to maekawa AT daemon-systems.org.
MAILADDR(7) Miscellaneous Information Manual MAILADDR(7) NAME mailaddr - mail addressing description DESCRIPTION Mail addresses are based on the Internet protocol listed at the end of this manual page. These addresses are in the general format user@domain where a domain is a hierarchical dot separated list of subdomains. For example, a valid address is: eric@CS.Berkeley.EDU Unlike some other (now obsolete) forms of addressing, domains do not imply any routing, or the existence of a particular host. Simply because mail may be sent to ``firstname.lastname@example.org'' does not imply that there is any actual host named ``somedomain.com'', and does not imply a particular routing of the message. Routing is performed by Mail Transport Agents, such as postfix(1), based on policies set in the MTA's configuration. Abbreviation Under certain circumstances it may not be necessary to type the entire domain name. In general, anything following the first dot may be omitted if it is the same as the domain from which you are sending the message. For example, a user on ``calder.berkeley.edu'' could send to ``eric@CS'' without adding the ``berkeley.edu'' since it is the same on both sending and receiving hosts. Whether abbreviation is permitted depends on how your site is configured. Case Distinctions Domain names (i.e., anything after the ``@'' sign) may be given in any mixture of upper and lower case. Most hosts accept any combination of case in user names, although there are exceptions. Postmaster Every site is required to have a user or user alias designated ``postmaster'' to which problems with the mail system may be addressed, for example: postmaster@CS.Berkeley.EDU Obsolete Formats Certain old address formats, such as UUCP ``bang path'' addresses, explicitly routed internet addresses (so-called ``route-addrs'' and the ``percent hack'') and others have been used historically. All these addressing formats are now considered obsolete, and should no longer be used. To some extent, MTAs attempt to provide backward compatibility for these addressing forms, but in practice many of them no longer work. Users should always use standard Internet style addresses. SEE ALSO mail(1) D. H. Crocker, Standard for the Format of Arpa Internet Text Messages, RFC, 822, August 1982. HISTORY mailaddr appeared in 4.2BSD. BUGS The RFC 822 group syntax (``group:user1,user2,user3;'') is not supported except in the special case of ``group:;'' because of a conflict with old berknet-style addresses, not that anyone cares about either berknet or group syntax style addresses any longer. NetBSD 8.99.34 June 16, 1998 NetBSD 8.99.34