I would appreciate any donations. Wishlist or send e-mail type donations to maekawa AT daemon-systems.org.
MPL115A(4) Kernel Interfaces Manual MPL115A(4) NAME mpl115a -- Freescale MPL115A2 absolute pressure sensor driver SYNOPSIS mpl115a* at iic? addr 0x60 DESCRIPTION The mpl115a driver provides support for the MPL115A2 pressure sensor. It allows reporting absolute pressure through the envsys(4) API. SEE ALSO envsys(4) HISTORY The mpl115a device first appeared in NetBSD 7.0. AUTHORS The mpl115a driver was written by Radoslaw Kujawa <firstname.lastname@example.org>. The fixed-point pressure calculation algorithm was suggested by Matt Thomas. CAVEATS The MPL115A2 chip has an accuracy of +/- 1 kPa, which makes it not very useful for weather-related applications. The envsys(4) API does not support pressure reporting yet, so the result is reported just as integer number. NetBSD 7.1.2 September 8, 2013 NetBSD 7.1.2