I would appreciate any donations. Wishlist or send e-mail type donations to maekawa AT daemon-systems.org.
NJATA(4) Kernel Interfaces Manual NJATA(4) NAME njata -- Workbit NinjaATA-32 CardBus IDE controller driver SYNOPSIS njata* at cardbus? function ? njata* at cardbus? function ? flags 0x01 # with wait 0x01 DESCRIPTION The njata driver provides support for the following Workbit Bus-Master CardBus IDE controller chips: NinjaATA-32Bi CardBus / PCMCIA dual mode IDE controller (``DuoATA''). This controller is mainly used for portable drives. This driver supports the CardBus mode. NPATA-32 CardBus IDE controller. This controller is widely used for CardBus CompactFlash adapters. These controllers are capable of bus-mastering for ATA PIO transfer. The njata driver uses the bus-mastering PIO transfer unless transfer buffer is unaligned, and significantly reduces CPU usage for PIO-only ATA devices compared with usual PIO transfer. CONFIGURATION The optional flags parameter is the ``wait'' value for ATA transfers. Some combinations of host and device may fail without flags parameter or flags 0x00. In this case try adding wait values like flags 0x01 or flags 0x11 (the wait parameter is composed of two 4bit values). Smaller wait values should be faster. Too long waits may cause transfer errors. SEE ALSO ata(4), atapi(4), cardbus(4), intro(4), wd(4), wdc(4) HISTORY The njata device driver first appeared in NetBSD 4.0. AUTHORS ITOH Yasufumi NetBSD 7.1.2 September 7, 2006 NetBSD 7.1.2