I would appreciate any donations. Wishlist or send e-mail type donations to maekawa AT daemon-systems.org.
PAM_FTPUSERS(8) System Manager's Manual PAM_FTPUSERS(8) NAME pam_ftpusers - ftpusers PAM module SYNOPSIS [service-name] module-type control-flag pam_ftpusers [options] DESCRIPTION The ftpusers service module for PAM provides functionality for only one PAM category: account management. In terms of the module-type parameter, this is the "account" feature. Ftpusers Account Management Module The ftpusers account management component (pam_sm_acct_mgmt()), succeeds if and only if the user is listed in /etc/ftpusers. The following options may be passed to the authentication module: debug syslog(3) debugging information at LOG_DEBUG level. no_warn suppress warning messages to the user. These messages include reasons why the user's authentication attempt was declined. disallow reverse the semantics; pam_ftpusers will succeed if and only if the user is not listed in /etc/ftpusers. SEE ALSO ftpusers(5), pam.conf(5), ftpd(8), pam(8) AUTHORS The pam_ftpusers module and this manual page were developed for the FreeBSD Project by ThinkSec AS and NAI Labs, the Security Research Division of Network Associates, Inc. under DARPA/SPAWAR contract N66001-01-C-8035 ("CBOSS"), as part of the DARPA CHATS research program. BUGS The current version of this module parses an older format of the ftpusers(5) file and should not be used. ftpd(8) will keep using its built-in ftpusers(5) parsing code until the parser code in the pam module is fixed. NetBSD 8.0 February 27, 2005 NetBSD 8.0