I would appreciate any donations. Wishlist or send e-mail type donations to maekawa AT daemon-systems.org.
PAM_RHOSTS(8) System Manager's Manual PAM_RHOSTS(8) NAME pam_rhosts -- rhosts PAM module SYNOPSIS [service-name] module-type control-flag pam_rhosts [options] DESCRIPTION The rhosts authentication service module for PAM provides functionality for only one PAM category: authentication. In terms of the module-type parameter, this is the ``auth'' feature. Rhosts Authentication Module The Rhosts authentication component (pam_sm_authenticate()), returns success if and only if the target user's UID is not 0 and the remote host and user are listed in /etc/hosts.equiv or in the target user's ~/.rhosts. The following options may be passed to the authentication module: debug syslog(3) debugging information at LOG_DEBUG level. no_warn suppress warning messages to the user. These messages include reasons why the user's authentication attempt was declined. allow_root do not automatically fail if the target user's UID is 0. SEE ALSO hosts.equiv(5), pam.conf(5), pam(8) AUTHORS The pam_rhosts module and this manual page were developed for the FreeBSD Project by ThinkSec AS and NAI Labs, the Security Research Division of Network Associates, Inc. under DARPA/SPAWAR contract N66001-01-C-8035 (``CBOSS''), as part of the DARPA CHATS research program. NetBSD 7.1.2 December 5, 2001 NetBSD 7.1.2