I would appreciate any donations. Wishlist or send e-mail type donations to maekawa AT daemon-systems.org.
PKG_SUMMARY(5) File Formats Manual PKG_SUMMARY(5) NAME pkg_summary -- summary of binary package repository DESCRIPTION The file pkg_summary contains information about each package in a binary package repository as a list of variable-value pairs. The variables describing different packages are separated by one empty line. Each line has the format VARIABLE=VALUE. If the value consists of more than one line, each line is prefixed with VARIABLE=. Multi-line variables are guaranteed to be in consecutive lines. The following variables are used: BUILD_DATE (required) The date and time when the package was built. CATEGORIES (required) A list of categories which this package fits in, separated by space. COMMENT (required) A one-line description of the package. CONFLICTS (optional) A list of dewey patterns of packages the package conflicts with, one per line. If missing, this package has no conflicts. DEPENDS (optional) A list of dewey patterns of packages the package depends on, one per line. If missing, this package has no dependencies. DESCRIPTION (required) A more detailed description of the package. FILE_CKSUM (optional) A checksum type supported by digest(1) and checksum separated by space character. FILE_NAME (optional) The name of the binary package file. If not given, PKGNAME.tgz can be assumed. FILE_SIZE (optional) The size of the binary package file, in bytes. HOMEPAGE (optional) A URL where more information about the package can be found. LICENSE (optional) The type of license this package is distributed under. If empty or missing, it is OSI-approved. MACHINE_ARCH (required) The architecture on which the package was compiled. OPSYS (required) The operating system on which the package was compiled. OS_VERSION (required) The version of the operating system on which the package was compiled. PKG_OPTIONS (optional) Any options selected to compile this package. If missing, the package does not support options. PKGNAME (required) The name of the package. PKGPATH (required) The path of the package directory within pkgsrc. PKGTOOLS_VERSION (required) The version of the package tools used to create the package. PREV_PKGPATH (optional) The previous path of the package directory within pkgsrc when a package was moved. (See SUPERSEDES below for a renamed package.) PROVIDES (optional) A list of shared libraries provided by the package, including major version number, one per line. If missing, this package does not provide shared libraries. REQUIRES (optional) A list of shared libraries needed by the package, including major version number, one per line. If missing, this package does not require shared libraries. SIZE_PKG (required) The size of the package when installed, in bytes. SUPERSEDES (optional) A list of dewey patterns of previous packages this package replaces, one per line. This is used for package renaming. The pkg_summary file can be generated using the pkg_info(1) -X option. For example, the following will list this data for all installed packages: pkg_info -X -a SEE ALSO digest(1), pkg_info(1) HISTORY The pkg_summary format was first officially documented in April 2006. NetBSD 7.1.2 April 11, 2009 NetBSD 7.1.2