Updated: 2022/Sep/29

Please read Privacy Policy. It's for your privacy.


POOL(9)                    Kernel Developer's Manual                   POOL(9)

NAME
     pool_init, pool_destroy, pool_get, pool_put, pool_prime, pool_sethiwat,
     pool_setlowat, pool_sethardlimit - resource-pool manager

SYNOPSIS
     #include <sys/pool.h>

     void
     pool_init(struct pool *pp, size_t size, u_int align, u_int align_offset,
         int flags, const char *wchan, struct pool_allocator *palloc,
         int ipl);

     void
     pool_destroy(struct pool *pp);

     void *
     pool_get(struct pool *pp, int flags);

     void
     pool_put(struct pool *pp, void *item);

     void
     pool_prime(struct pool *pp, int n);

     void
     pool_sethiwat(struct pool *pp, int n);

     void
     pool_setlowat(struct pool *pp, int n);

     void
     pool_sethardlimit(struct pool *pp, int n, const char *warnmess,
         int ratecap);

DESCRIPTION
     These utility routines provide management of pools of fixed-sized areas
     of memory.  Resource pools set aside an amount of memory for exclusive
     use by the resource pool owner.  This can be used by applications to
     guarantee the availability of a minimum amount of memory needed to
     continue operation independent of the memory resources currently
     available from the system-wide memory allocator (malloc(9)).

   INITIALIZING A POOL
     The function pool_init() initializes a resource pool.  The arguments are:

           pp            The handle identifying the pool resource instance.

           size          Specifies the size of the memory items managed by the
                         pool.

           align         Specifies the memory address alignment of the items
                         returned by pool_get().  This argument must be a
                         power of two.  If zero, the alignment defaults to an
                         architecture-specific natural alignment.

           align_offset  The offset within an item to which the align
                         parameter applies.

           flags         Should be set to zero, PR_NOTOUCH, or PR_PSERIALIZE.
                         If PR_NOTOUCH is given, free items are never used to
                         keep internal state so that the pool can be used for
                         non memory backed objects.  If PR_PSERIALIZE is
                         given, then the allocator guarantees that a passive
                         serialization barrier equivalent to "xc_barrier(0)"
                         will be performed before the object's backing store
                         is returned to the system.  PR_PSERIALIZE implies
                         PR_NOTOUCH.  Because of the guarantees provided by
                         PR_PSERIALIZE, objects muste never be freed to a pool
                         using this option from either hard or soft interrupt
                         context, as doing so may block.

           wchan         The `wait channel' passed on to cv_wait(9) if
                         pool_get() must wait for items to be returned to the
                         pool.

           palloc        Can be set to NULL or pool_allocator_kmem, in which
                         case the default kernel memory allocator will be
                         used.  It can also be set to pool_allocator_nointr
                         when the pool will never be accessed from interrupt
                         context.

           ipl           Specifies an interrupt priority level that will block
                         all interrupt handlers that could potentially access
                         the pool.

   DESTROYING A POOL
     The function pool_destroy() destroys a resource pool.  It takes a single
     argument pp identifying the pool resource instance.

   ALLOCATING ITEMS FROM A POOL
     pool_get() allocates an item from the pool and returns a pointer to it.
     The arguments are:

           pp     The handle identifying the pool resource instance.

           flags  The flags can be used to define behaviour in case the pooled
                  resources are depleted.  If no resources are available and
                  PR_NOWAIT is given, pool_get() returns NULL.  If PR_WAITOK
                  is given and allocation is attempted with no resources
                  available, the function will sleep until items are returned
                  to the pool.  If both PR_LIMITFAIL and PR_WAITOK are
                  specified, and the pool has reached its hard limit,
                  pool_get() will return NULL without waiting, allowing the
                  caller to do its own garbage collection; however, it will
                  still wait if the pool is not yet at its hard limit.  If the
                  PR_ZERO flag is specified, then the memory returned will be
                  zeroed first using memset(3).

   RETURNING ITEMS TO A POOL
     pool_put() returns the pool item pointed at by item to the resource pool
     identified by the pool handle pp.  If the number of available items in
     the pool exceeds the maximum pool size set by pool_sethiwat() and there
     are no outstanding requests for pool items, the excess items will be
     returned to the system.  The arguments to pool_put() are:

           pp    The handle identifying the pool resource instance.

           item  A pointer to a pool item previously obtained by pool_get().

   SETTING POOL RESOURCE WATERMARKS AND LIMITS
     A pool will attempt to increase its resource usage to keep up with the
     demand for its items.  Conversely, it will return unused memory to the
     system should the number of accumulated unused items in the pool exceed a
     programmable limit.

     The targets for the minimum and maximum number of free items which a pool
     should try to keep available are known as the high and low watermarks.
     The functions pool_sethiwat() and pool_setlowat() set a pool's high and
     low watermarks, respectively.

     The limits for the minimum and maximum number of total items (both free
     and allocated) that the pool can have at any time are specified by the
     functions pool_prime() and pool_sethardlimit(), respectively.  The
     defaults for these limits are 0 and UINT_MAX, respectively.  Changing
     these limits will cause memory to be immediately allocated to the pool or
     freed from the pool as needed.

     pool_sethiwat()

           pp     The handle identifying the pool resource instance.

           n      The maximum number of free items to keep in the pool.  As
                  items are returned and the total number of free items in the
                  pool is larger than the maximum set by this function, any
                  completely unused pages are released immediately.  If this
                  function is not used to specify a maximum number of items,
                  the pages will remain associated with the pool until the
                  system runs low on memory, at which point the VM system will
                  try to reclaim unused pages.

     pool_setlowat()

           pp     The handle identifying the pool resource instance.

           n      The minimum number of free items to keep in the pool.  When
                  the number of free items in the pool drops below this
                  threshold, a non-blocking attempt is made to allocate memory
                  for more items.  The number of free items is not guaranteed
                  to remain above this threshold.

     pool_sethardlimit()

           pp     The handle identifying the pool resource instance.

           n      The maximum number of total items in the pool (i.e. the hard
                  limit).

           warnmess
                  The warning message that will be logged when the hard limit
                  is reached.

           ratecap
                  The minimal interval (in seconds) after which another
                  warning message is issued when the pool hits its hard limit
                  again.

     pool_prime()

           pp       The handle identifying the pool resource instance.

           n        The minimum number of total items for the pool.  If the
                    current number of total items is less than the new minimum
                    then new items are allocated with blocking allocations.

   POTENTIAL PITFALLS
     Note that undefined behaviour results when mixing the storage providing
     methods supported by the pool resource routines.

     The pool resource code uses a per-pool lock to protect its internal
     state.  If any pool functions are called in an interrupt context, the
     caller must block all interrupts that might cause the code to be
     reentered.  Additionally, the functions pool_init() and pool_destroy()
     should never be called in interrupt context.

   DIAGNOSTICS
     Pool usage logs can be enabled by defining the compile-time option
     POOL_DIAGNOSTIC.

CODE REFERENCES
     The pool manager is implemented in the file sys/kern/subr_pool.c.

SEE ALSO
     free(9), malloc(9), memoryallocators(9), pool_cache(9), uvm(9)

HISTORY
     The NetBSD pool manager appeared in NetBSD 1.4.

NetBSD 10.99                    April 12, 2020                    NetBSD 10.99