I would appreciate any donations. Wishlist or send e-mail type donations to maekawa AT daemon-systems.org.
RANLIB(5) File Formats Manual RANLIB(5) NAME ranlib -- a.out archive (library) table-of-contents format SYNOPSIS #include <ranlib.h> DESCRIPTION The archive table-of-contents command ranlib creates a table of contents for archives, containing object files, to be used by the link-editor ld(1). It operates on archives created with the utility ar(1). The ranlib function prepends a new file to the archive which has three separate parts. The first part is a standard archive header, which has a special name field, "__.SYMDEF". The second part is a ``long'' followed by a list of ranlib structures. The long is the size, in bytes, of the list of ranlib structures. Each of the ranlib structures consists of a zero based offset into the next section (a string table of symbols) and an offset from the beginning of the archive to the start of the archive file which defines the symbol. The actual number of ranlib structures is this number divided by the size of an individual ranlib structure. The third part is a ``long'' followed by a string table. The long is the size, in bytes of the string table. SEE ALSO ar(1), ranlib(1) BUGS The <ranlib.h> header file, and the ranlib manual page, do not describe the table-of-contents used by ELF systems, which is that from the AT&T System V Release 4 UNIX ABI. NetBSD 7.1.2 June 6, 1993 NetBSD 7.1.2