I would appreciate any donations. Wishlist or send e-mail type donations to maekawa AT daemon-systems.org.
RTFPS(4) Kernel Interfaces Manual RTFPS(4) NAME rtfps -- multiplexing serial communications interface SYNOPSIS rtfps0 at isa? port 0x1230 irq 10 com2 at rtfps0 slave 0 com3 at rtfps0 slave 1 com4 at rtfps0 slave 2 com5 at rtfps0 slave 3 DESCRIPTION The rtfps driver provides support for IBM RT PC boards that multiplex together up to four EIA RS-232C (CCITT V.28) or RS-422A communications interfaces. Each rtfps device is the master device for up to four com devices. The kernel configuration specifies these com devices as slave devices of the rtfps device, as shown in the synopsis. The port specification for the rtfps device is used to compute the base addresses for the com subdevices. FILES /dev/tty0? SEE ALSO com(4) HISTORY The rtfps driver was written by Charles Hannum, based on the ast driver. BUGS The rtfps driver is unlikely to work on non-EISA and non-PCI machines. The ISA bus only asserts 10 I/O address lines, and this is not enough. Even on EISA and PCI machines, some address conflicts have been observed. On one machine, the second port always conflicted with something (though it's not clear what) and caused strange results. Disabling the second port in the kernel config allowed the other three ports to function correctly. NetBSD 7.1.2 August 7, 1994 NetBSD 7.1.2