I would appreciate any donations. Wishlist or send e-mail type donations to maekawa AT daemon-systems.org.
RUMP_FFS(8) System Manager's Manual RUMP_FFS(8) NAME rump_ffs -- mount a ffs image with a userspace server SYNOPSIS file-system PUFFS pseudo-device putter rump_ffs [options] image mountpoint DESCRIPTION NOTE! This manual page describes features specific to the rump(3) file server. Please see mount_ffs(8) for a full description of the available command line options. The rump_ffs utility can be used to mount ffs file systems. It uses rump(3) and p2k(3) to facilitate running the file system as a server in userspace. As opposed to mount_ffs(8), rump_ffs does not use file system code within the kernel and therefore does not require kernel support except puffs(4). Apart from a minor speed penalty there is no downside with respect to in-kernel code. rump_ffs does not require using vnconfig(8) for mounts from regular files and the file path can be passed directly as the image parameter. In fact, the use of vnconfig(8) is discouraged, since it is unable to properly deal with images on sparse files. In case the image contains multiple partitions, the desired partition must be indicated by appending the token ``%DISKLABEL:p%'' to the image path. The letter ``p'' specifies the partition as obtained via disklabel(8). For example, to mount partition ``e'' from image /tmp/wd0.img, use ``/tmp/wd0.img%DISKLABEL:e%''. It is recommended that untrusted file system images be mounted with rump_ffs instead of mount_ffs(8). Corrupt file system images commonly cause the file system to crash the entire kernel, but with rump_ffs only the userspace server process will dump core. To use rump_ffs via mount(8), the flags -o rump and -t ffs should be given. Similarly, rump_ffs is used instead of mount_ffs(8) if ``rump'' is added to the options field of fstab(5). SEE ALSO p2k(3), puffs(3), rump(3), mount_ffs(8) HISTORY The rump_ffs utility first appeared in NetBSD 5.0. NetBSD 7.1.2 November 21, 2010 NetBSD 7.1.2