I would appreciate any donations. Wishlist or send e-mail type donations to maekawa AT daemon-systems.org.
RUMP_TMPFS(8) System Manager's Manual RUMP_TMPFS(8) NAME rump_tmpfs -- mount a tmpfs fictional fs with a userspace server SYNOPSIS file-system PUFFS pseudo-device putter rump_tmpfs [options] tmpfs mountpoint DESCRIPTION NOTE! This manual page describes features specific to the rump(3) file server. Please see mount_tmpfs(8) for a full description of the available command line options. The rump_tmpfs utility can be used to mount tmpfs file systems. It uses rump(3) and p2k(3) to facilitate running the file system as a server in userspace. As opposed to mount_tmpfs(8), rump_tmpfs does not use file system code within the kernel and therefore does not require kernel support except puffs(4). Apart from a minor speed penalty there is no downside with respect to in-kernel code. To use rump_tmpfs via mount(8), the flags -o rump and -t tmpfs should be given. Similarly, rump_tmpfs is used instead of mount_tmpfs(8) if ``rump'' is added to the options field of fstab(5). SEE ALSO p2k(3), puffs(3), rump(3), mount_tmpfs(8) HISTORY The rump_tmpfs utility first appeared in NetBSD 5.0. NetBSD 7.1.2 November 21, 2010 NetBSD 7.1.2