I would appreciate any donations. Wishlist or send e-mail type donations to maekawa AT daemon-systems.org.
RUMPFS(4) Kernel Interfaces Manual RUMPFS(4) NAME rumpfs -- rump kernel root file system LIBRARY rump kernel (librumpvfs, -lrumpvfs) DESCRIPTION rumpfs is a simple in-memory file system for rump kernels. It is automatically mounted as the root file system of a rump kernel at boot time, provided that the VFS faction is configured into the rump kernel instance. The three main features of rumpfs are: 1. providing a hook for accessing host files via the rump_etfs(3) interfaces. 2. supporting enough of file and directory interfaces to facilitate simple operations such as hosting config files or creating mount points. 3. being small and lightweight so as to keep a barebones rump kernel lightweight. rumpfs is not intended for hosting large files or big directory hierarchies. If faced with such a use case, mounting a tmpfs file system inside the rump kernel is recommended. SEE ALSO rump(3) HISTORY rumpfs first appeared in NetBSD 6.0. NetBSD 7.1.2 March 3, 2014 NetBSD 7.1.2