I would appreciate any donations. Wishlist or send e-mail type donations to maekawa AT daemon-systems.org.
SEEPROM(4) Kernel Interfaces Manual SEEPROM(4) NAME seeprom -- 24-series I2C EEPROM driver SYNOPSIS seeprom0 at iic0 addr 0x51: AT24Cxx or compatible EEPROM: size 256 seeprom16 at iic1 addr 0x57: power-supply: size 8192 DESCRIPTION The seeprom driver provides support for the ATMEL 24-series of I2C EEPROMs, and compatibles, available from a variety of vendors. The Philips PCF8582 is also supported, as compatible with the AT24C02. Access to the contents of the memory is through a character device. The size of the EEPROM is either read from the firmware, or can be set using the flags keyword in the kernel configuration. The value of the flag represents the EEPROM size in Kbit. flags EEPROM size in bytes 1 128 2 256 4 512 8 1024 16 2048 32 4096 64 8192 128 16384 256 32768 512 65536 EXAMPLES Indirect configuration: seeprom* at iic? addr 0x51 flags 0x2 Direct configuration: seeprom* at iic? addr? SEE ALSO iic(4) HISTORY The seeprom device appeared in NetBSD 2.0. BUGS AT24C1024 EEPROM's are not supported. Software write protection on the AT34Cxx EEPROMs is not supported. The seeprom driver reads and writes one byte at a time to be compatible with all controllers. NetBSD 7.1.2 October 25, 2013 NetBSD 7.1.2