I would appreciate any donations. Wishlist or send e-mail type donations to maekawa AT daemon-systems.org.
SI(4) Kernel Interfaces Manual SI(4) NAME si, sw -- NCR 5380 SCSI bus host adaptor driver SYNOPSIS sun3 si0 at obio0 addr 0x140000 ipl 2 sun3 and sun3x si0 at vme2 addr 0x200000 ipl 2 vect 0x40 si1 at vme2 addr 0x204000 ipl 2 vect 0x41 sun3/E sebuf0 at vme2 addr 0x300000 ipl 2 vect 0x74 # and 0x75 sebuf1 at vme2 addr 0x340000 ipl 2 vect 0x76 # and 0x77 si* at sebuf? sun4 and sun2 si0 at vme0 addr 0x200000 pri 2 vec 0x40 sun4/100 sw0 at obio0 addr 0x0a000000 level 3 DESCRIPTION The si and sw "SCSI Weird" drivers provide support for the NCR 5380 SCSI Bus Controller (SBC) chip found on various Sun Microsystems CPU motherboards (obio), and on the "Sun-3 VME SCSI" (Sun part # 501-1236) board used in systems with VME bus. sun3 and sun3x The sun3 and sun3x version of this driver can be configured with a flags directive in the config(1) file. The values are bits in a bitfield, and are interpreted as follows: 0x000ff Set bit (1<<target) to disable SCSI disconnect/reselect 0x0ff00 Set bit (1<<(target+8)) to disable SCSI parity checking 0x10000 Set this bit to disable DMA interrupts (poll) 0x20000 Set this bit to disable DMA entirely (use PIO) For example: "flags 0x1000f" would disable DMA interrupts, and disable disconnect/reselect for targets 0-3. The "target" is the SCSI ID number of a particular device on a particular SCSI bus. sun4 The sun4 version of this driver can also be configured with a flags directive in the config(1) file. The values are bits in a bitfield, and are interpreted as follows: 0x01 Use DMA (may be polled) 0x02 Use DMA completion interrupts 0x04 Allow SCSI disconnect/reselect For example: "flags 0x07" would enable DMA, interrupts, and reselect. By default, DMA is enabled in the sun4 driver. SEE ALSO cd(4), ch(4), intro(4), scsi(4), sd(4), st(4) AUTHORS David Jones, Gordon Ross <gwr@NetBSD.org>, Adam Glass <glass@NetBSD.org>, Jason R. Thorpe <thorpej@NetBSD.org>. BUGS The VME variant has a bit to enable or disable the DMA engine, but that bit also gates the interrupt line from the NCR5380 (!!). Therefore, in order to get any interrupt from the NCR5380, (i.e. for reselect) one must clear the DMA engine transfer count and then enable DMA. This has the further complication that you CAN NOT touch the NCR5380 while the DMA enable bit is set, so we have to turn DMA back off before we even look at the NCR5380. Support for the Sun 4/100 sw "SCSI Weird" is not complete. DMA works, but interrupts (and, thus, reselection) don't for reasons unknown. Further progress has halted pending the availability of a machine for testing. DMA, DMA completion interrupts, and reselection work fine on a Sun 4/260 with modern SCSI-II disks attached. There have been reports of reselection failing on Sun Shoebox-type configurations where there are multiple non-SCSI devices behind Emulex or Adaptec bridges. These devices pre-date the SCSI-I spec, and might not behave the way the NCR5380 code expects. For this reason, only DMA is enabled by default in the sun4 driver. NetBSD 7.1.2 May 7, 1998 NetBSD 7.1.2