I would appreciate any donations. Wishlist or send e-mail type donations to maekawa AT daemon-systems.org.
SYSMON(4) Device Drivers Manual SYSMON(4) NAME sysmon - system monitoring and power management interface DESCRIPTION The machine-independent sysmon is a general purpose framework for system monitoring and power management. The main components of sysmon include: ⊕ An ioctl(2) interface available via /dev/sysmon. The userland counterparts include utilities such as envstat(8) and daemons such as powerd(8). ⊕ An interface for the purpose of delivering different system and power events to userspace; sysmon_pswitch(9). ⊕ A general purpose sensor framework, sysmon_envsys(9). ⊕ A general purpose task queue, sysmon_taskq(9). ⊕ An interface for watchdog timers. FILES /dev/sysmon SEE ALSO envsys(4), swsensor(4), envstat(8), powerd(8), wdogctl(8), pmf(9) AUTHORS Jason R. Thorpe <thorpej@NetBSD.org> NetBSD 8.0 June 22, 2011 NetBSD 8.0