I would appreciate any donations. Wishlist or send e-mail type donations to maekawa AT daemon-systems.org.
TCOM(4) Kernel Interfaces Manual TCOM(4) NAME tcom -- multiplexing serial communications interface SYNOPSIS For 4-port TC-400 series boards: tcom0 at isa? port 0x100 irq 5 com2 at tcom? slave ? com3 at tcom? slave ? com4 at tcom? slave ? com5 at tcom? slave ? For 8-port TC-800 series boards: tcom0 at isa? port 0x100 irq 5 com2 at tcom? slave ? com3 at tcom? slave ? com4 at tcom? slave ? com5 at tcom? slave ? com6 at tcom? slave ? com7 at tcom? slave ? com8 at tcom? slave ? com9 at tcom? slave ? DESCRIPTION The tcom driver provides support for the Byte Runner Technologies TC-400 and TC-800 series boards that multiplex together up to four or eight EIA RS-232C (CCITT V.28) communications interfaces. Each tcom device is the master device for up to eight com devices. The kernel configuration specifies these com devices as slave devices of the tcom device, as shown in the synopsis. The slave ID given for each com device determines which bit in the interrupt multiplexing register is tested to find interrupts for that device. The port specification for the tcom device is used to compute the base addresses for the com subdevices and the port for the interrupt multiplexing register. Not all possible configuration options are currently supported (for example, speeds beyond 115200 baud are not currently supported). FILES /dev/tty?? SEE ALSO com(4) HISTORY The tcom driver was written by Jukka Marin. NetBSD 7.1.2 May 20, 1998 NetBSD 7.1.2