I would appreciate any donations. Wishlist or send e-mail type donations to maekawa AT daemon-systems.org.
TEA5767RADIO(4) Device Drivers Manual TEA5767RADIO(4) NAME tea5767 - Philips/NXP TEA5767 FM Chip SYNOPSIS tea5767radio* at iic? addr 0x60 flags 0x00 radio* at tea5767radio? DESCRIPTION The tea5767 driver provides support for the Philips/NXP TEA5767 FM stereo radio. The tea5767 can tune in the range 87.5 - 108.0 MHz, perform hardware signal search and supports mono/stereo toggling. The flags control the FM Band, XTAL, and PLL values as follows: 0x01 Sets the FM Band to Japan. 0x02 Sets the PLL bit. 0x04 Sets the XTAL bit. 0x08 Force enables hardware search support. SEE ALSO iic(4), radio(4), radio(9) TEA5767, Low-power FM stereo radio, Rev. 05, 26 January 2007. CAVEATS Many popular TEA5767 evaluation boards feature low quality 32.768kHz crystals. The inaccuracy of these crystals may often lead to malfunction of the hardware search funciton. Therefore, the tea5767 driver tries to detect the crystal quality during attachment. If the crystal of insufficient accuracy was detected, the hardware search function is disabled. It can be forcefully re-enabled by setting the 0x08 flag. NetBSD 8.99.34 July 6, 2018 NetBSD 8.99.34