I would appreciate any donations. Wishlist or send e-mail type donations to maekawa AT daemon-systems.org.
VTE(4) Kernel Interfaces Manual VTE(4) NAME vte -- Vortex86 RDC R6040 Fast Ethernet driver SYNOPSIS vte* at pci? dev ? function ? Configuration of PHYs is necessary. See rdcphy(4). DESCRIPTION The vte device driver provides support for RDC R6040 Fast Ethernet controller which is commonly found on Vortex86 System On a Chip (SoC). The RDC R6040 has integrated 10/100 PHY for 10/100Mbps support in full or half-duplex. The controller supports interrupt moderation mechanism, a 64-bit multicast hash filter, VLAN over-size frame and four station addresses. The vte device driver uses three station addresses out of four as perfect multicast filter. SYSCTL VARIABLES The following variables are available hw.vte.vte<x>.int_rxct Maximum number of packets to fire RX completion interrupt. The accepted range is 0 (disable interrupt moderation) to 15, the default is 0. hw.vte.vte<x>.int_txct Maximum number of packets to fire TX completion interrupt. The accepted range is 0 (disable interrupt moderation) to 15, the default is 0. SEE ALSO ifmedia(4), mii(4), netintro(4), vlan(4), ifconfig(8) DM&P Electronics Inc. Vortex86, http://www.dmp.com.tw. HISTORY The vte driver was written for FreeBSD by Pyun YongHyeon <yongari@FreeBSD.org> and ported to NetBSD by Manuel Bouyer <bouyer@NetBSD.org>. The vte device driver first appeared in NetBSD 6.0. NetBSD 7.1.2 January 23, 2011 NetBSD 7.1.2