I would appreciate any donations. Wishlist or send e-mail type donations to maekawa AT daemon-systems.org.
AKBD(4) Device Drivers Manual AKBD(4) NAME akbd - Apple Desktop Bus keyboard driver for wscons SYNOPSIS akbd* at obio? wskbd* at akbd? console ? options ALTXBUTTONS options CAPS_IS_CONTROL options FORCE_FUNCTION_KEYS DESCRIPTION This driver provides the wscons(4) driver with support for Apple Desktop Bus keyboards. To work around the limited number of buttons found on most ADB mice, one can map key sequences to trigger mouse button events. To map Option+1, Option+2, Option+3 to mouse buttons 1, 2, and 3 respectively, add the following line to your kernel configuration file: options ALTXBUTTONS On macppc systems it is possible to tweak the keyboard driver to treat the caps lock key on an ADB keyboard as a control key. This requires special remapping because of ADB's strange emulation of a mechanically- locked key. To enable this code add the following line to your kernel configuration file: options CAPS_IS_CONTROL On macppc PowerBooks, several function keys double as "hot keys" (brightness, volume, eject) when the Fn modifier is held down. Mac OS X likes to reprogram the keyboard controller to send hot key events when Fn is not held down and send function key events when it is. To transform the non-keyboard "button" events back into function key events, place the following line in your kernel configuration file: options FORCE_FUNCTION_KEYS SUPPORTED HARDWARE NetBSD is known to support the following ADB keyboards: ⊕ On-board keyboards on PowerBook models ⊕ Apple Standard Keyboard ⊕ Apple Keyboard II ⊕ Apple Extended Keyboard ⊕ Apple Extended Keyboard II ⊕ Apple Adjustable Keyboard ⊕ Most third-party ADB keyboards are supported SEE ALSO adb(4), wscons(4), wskbd(4), wsconsctl(8) BUGS The number pad on extended keyboards does not send out the proper key codes for many applications. The LEDs on extended keyboards are not functional under NetBSD. NetBSD 8.0 September 21, 2003 NetBSD 8.0