I would appreciate any donations. Wishlist or send e-mail type donations to maekawa AT daemon-systems.org.
ATPPC(4) Kernel Interfaces Manual ATPPC(4) NAME atppc -- driver for AT-style parallel port chip sets SYNOPSIS atppc* at acpi? atppc* at isa? port 0x378 irq 7 drq 3 flags 0x00 atppc* at isapnp? atppc* at ofisa? atppc* at pnpbios? index ? atppc* at puc? port ? options ATPPC_VERBOSE options ATPPC_DEBUG DESCRIPTION atppc supports parallel ports and provides the low level support needed by higher level drivers such as ppbus(4). This driver attaches where the traditional NetBSD lpt(4) driver would ordinarily. It provides the data transport and chip set manipulation needed by higher driver layers, such as ppbus(4) and lpt(4). This driver is designed to be one of many possible implementations supporting machine independent parallel device support via ppbus(4). IEEE 1284 support atppc is intended to provide to data-link like services to higher level IEEE 1284 device drivers (such as ppbus(4)). atppc does not directly support IEEE 1284 features such as mode negotiation but rather provides the necessary infrastructure to allow a higher level driver to provide these services. atppc does provide chip set manipulation, device handshakes (where appropriate), low-level error detection, and data transfer. Supported data transfer modes atppc supports the following data transfer modes: Centronics Compatible (Standard), Nibble, Byte (PS2), Fast Centronics, ECP, and EPP. Standard and Fast Centronics modes are write only, Nibble and Byte modes are read only, and ECP and EPP modes are bidirectional. SEE ALSO acpi(4), i386/pnpbios(4), isa(4), isapnp(4), lpt(4), ofisa(4), ppbus(4), puc(4) HISTORY The atppc driver is based on the ppc driver, which originally appeared in FreeBSD. The driver was ported over in NetBSD 2.0. AUTHORS This manual page is based on the FreeBSD ppc manual page. The information has been updated for the NetBSD port by Gary Thorpe. BUGS The FreeBSD driver includes support for some specific chip sets, specifically detection of some non-standard device I/O locations on the ISA bus. This support was not ported over to the NetBSD version of the driver yet. NetBSD 7.1.2 January 30, 2004 NetBSD 7.1.2