I would appreciate any donations. Wishlist or send e-mail type donations to maekawa AT daemon-systems.org.
ISAPNP(4) Device Drivers Manual ISAPNP(4) NAME isapnp - introduction to ISA Plug-and-Play support SYNOPSIS isapnp0 at isa? An isapnp bus can be configured for each supported ISA bus. DESCRIPTION NetBSD provides machine-independent bus support and drivers for ISA Plug- and-Play (isapnp) autoconfiguration of PnP-compatible devices on an ISA bus. SUPPORTED DEVICES NetBSD includes machine-independent ISAPNP drivers, sorted by function and driver name: SCSI interfaces aha Adaptec AHA-154 SCSI interfaces. aic Adaptec AHA-1520B SCSI interfaces. Disk controllers wdc Standard IDE and ATAPI drive controller. Serial and parallel interfaces com 8250/16450/16550-compatible ISA PnP serial cards and internal modems. Network interfaces an Aironet 4500/4800 and Cisco 340 series 802.11 interfaces. ep 3Com 3c509B EtherLink III Ethernet interface. le PCnet-PnP Ethernet interfaces based on the successor to the AMD LANCE chip. ne NE2000-compatible Ethernet interfaces. tr TROPIC based token ring interfaces. Sound cards ess ESS Technology derived PnP sound cards and devices. guspnp Gravis Ultrasound PnP sound cards. sb SoundBlaster, SoundBlaster 16, and SoundBlaster Pro sound cards. wss Windows Sound System compatible cards, e.g., most of the cards with Crystal Semiconductor chips. ym Yamaha OPL3-SAx sound cards. Miscellaneous devices pcic PCI PCMCIA controllers, including the Cirrus Logic GD6729. ISA Plug-and-Play devices also have alternate ISA drivers with static ISA IO address configuration. These are listed in isa(4). The isapnp bus ignores devices that have already been found and configured as isa(4) devices. The isapnp bus is only effective on machines which lack a PnP BIOS, or on which the PnP BIOS has been disabled. The manual pages for each individual isapnp driver also list the supported front-ends for other buses. SEE ALSO aha(4), aic(4), an(4), com(4), ep(4), ess(4), guspnp(4), intro(4), isa(4), le(4), ne(4), pcic(4), sb(4), tr(4), wdc(4), wss(4), ym(4) HISTORY The isapnp driver appeared in NetBSD 1.3. NetBSD 8.0 February 17, 1997 NetBSD 8.0