I would appreciate any donations. Wishlist or send e-mail type donations to maekawa AT daemon-systems.org.
WSS(4) Kernel Interfaces Manual WSS(4) NAME wss -- Windows Sound System hardware audio driver SYNOPSIS wss0 at isa? port 0x530 irq 10 drq 0 drq2 1 wss0 at isa? port 0x530 irq 10 drq 0 flags 1 wss* at acpi? wss* at isapnp? wss* at pnpbios? index ? audio* at audiobus? opl* at wss? DESCRIPTION The wss driver supports Microsoft's Windows Sound System, the MAD16 chip based hardware, and their clones. The base I/O port is set by a jumper on the board; valid choices are 0x530, 0x604, 0xE80, or 0xF40. Both IRQ and DMA channels are software programmable. The IRQ may be set to 7, 9, 10, or 11, and the DMA channel may be set to 0, 1, or 3. The device flags must have bit 0 (value 1) set to enable the MAD16 support. This is to avoid potential conflicts with other devices when probing the MAD16 because it requires use of extra I/O ports not in the base port range. Chips needing this flag include the OPTi 82C928, 82C929, 82C831, and the OAK OTI-601D. Setting bit 1 (value 2) in flags disables the joystick port on MAD16 hardware. SEE ALSO acpi(4), audio(4), isa(4), isapnp(4), joy(4), opl(4), pnpbios(4) NetBSD 7.1.2 June 22, 2005 NetBSD 7.1.2