Updated: 2022/Sep/29

Please read Privacy Policy. It's for your privacy.


JOY(4)                       Device Drivers Manual                      JOY(4)

NAME
     joy - game adapter driver

SYNOPSIS
     joy* at acpi?
     joy* at eap?
     joy* at eso?
     joy0 at isa? port 0x201
     joy* at isapnp?
     joy* at ofisa?
     joy* at pci?
     joy* at pnpbios? index ?

DESCRIPTION
     This driver provides access to the game adapter.  The lower bit in the
     minor device number selects the joystick: 0 is the first joystick and 1
     is the second.

     The game control adapter allows up to two joysticks to be attached to the
     system.  The adapter plus the driver convert the present resistive value
     to a relative joystick position.  On receipt of an output signal, four
     timing circuits are started.  By determining the time required for the
     circuit to time-out (a function of the resistance), the paddle position
     can be determined.  The adapter could be used as a general purpose I/O
     card with four analog (resistive) inputs plus four digital input points.

     Applications may call ioctl(2) on a game adapter driver file descriptor
     to set and get the offsets of the two potentiometers and the maximum
     time-out value for the circuit.  The ioctl(2) commands are listed in
     <machine/joystick.h> and currently are:

     JOY_SETTIMEOUT    Sets the maximum time-out for the adapter.
     JOY_GETTIMEOUT    Returns the current maximum time-out.
     JOY_SET_X_OFFSET  Sets an offset on X value.
     JOY_GET_X_OFFSET  Returns the current X offset.
     JOY_SET_Y_OFFSET  Sets an offset on Y value.
     JOY_GET_Y_OFFSET  Returns the current Y offset.

     All these commands take an integer parameter.

     read(2) on the file descriptor returns a joystick structure:

           struct joystick {
                   int x;
                   int y;
                   int b1;
                   int b2;
           };

     The fields have the following functions:

     x    current X coordinate of the joystick (or position of paddle 1)

     y    current Y coordinate of the joystick (or position of paddle 2)

     b1   current state of button 1

     b2   current state of button 2

     The b1 and b2 fields in struct joystick are set to 1 if the corresponding
     button is down, 0 otherwise.

     The x and y coordinates are supposed to be between 0 and 255 for a good
     joystick and a good adapter.  Unfortunately, because of the hardware hack
     that is used to measure the position (by measuring the time needed to
     discharge an RC circuit made from the joystick's potentiometer and a
     capacitor on the adapter), calibration is needed to determine exactly
     what values are returned for a specific joystick/adapter combination.
     Incorrect hardware can yield negative or values greater than 255.

     A typical calibration procedure uses the values returned at lower left,
     center and upper right positions of the joystick to compute the relative
     position.

     This calibration is not part of the driver.

FILES
     /dev/joy0                         first joystick
     /dev/joy1                         second joystick

SEE ALSO
     acpi(4), eap(4), eso(4), isa(4), isapnp(4), ofisa(4), pci(4), pnpbios(4)

AUTHORS
     Jean-Marc Zucconi wrote the FreeBSD driver.  Matthieu Herrb ported it to
     NetBSD and wrote this manual page.

NetBSD 10.99                     July 22, 2006                    NetBSD 10.99