Updated: 2022/Sep/29

Please read Privacy Policy. It's for your privacy.


PCI(4)                       Device Drivers Manual                      PCI(4)

NAME
     pci - introduction to machine-independent PCI bus support and drivers

SYNOPSIS
     pci* at mainbus? bus ?
     pci* at pchb? bus ?
     pci* at ppb? bus ?

     options PCIVERBOSE
     options PCI_CONFIG_DUMP
     options PCI_ADDR_FIXUP
     options PCI_BUS_FIXUP
     options PCI_INTR_FIXUP

DESCRIPTION
     NetBSD includes a machine-independent PCI bus subsystem and several
     machine-independent PCI device drivers.

     Your system may support additional PCI devices and attachments.  Drivers
     for PCI devices not listed here are machine-dependent.  Consult your
     system's intro(4) for additional information.

OPTIONS
        PCI_ADDR_FIXUP  Fixup PCI I/O and memory addresses.

                        Some i386 and amd64 BIOS implementations don't
                        allocate I/O space and memory space for some PCI
                        devices -- primarily BIOS in PnP mode, or laptops that
                        expect devices to be configured via ACPI.  Since
                        necessary space isn't allocated, those devices will
                        not work without special handling.

                        This option allocates I/O space and memory space
                        instead of relying upon the BIOS to do so.

                        If necessary space is already correctly assigned to
                        the devices, this option leaves the space as is.

        PCI_BUS_FIXUP   Fixup PCI bus numbering; needed for many cardbus(4)
                        bridges.

                        Each PCI bus and CardBus should have a unique bus
                        number.  But some BIOS implementations don't assign a
                        bus number for subordinate PCI buses.  And many BIOS
                        implementations don't assign a bus number for
                        CardBuses.

                        A typical symptom of this is the following boot
                        message:
                              cardbus0 at cardslot0: bus 0 device 0...
                        Please note that this cardbus0 has a bus number `0',
                        but normally the bus number 0 is used by the machine's
                        primary PCI bus.  Thus, this bus number for cardbus is
                        incorrect (not assigned).  In this situation, a device
                        located in cardbus0 doesn't show correct device ID,
                        because its bus number 0 incorrectly refers to the
                        primary PCI bus, and a device ID in the primary PCI
                        bus is shown in the boot message instead of the
                        device's ID in the cardbus0.

                        This option assigns bus numbers for all subordinate
                        PCI buses and CardBuses.

                        Since this option renumbers all PCI buses and
                        CardBuses, all bus numbers of subordinate buses become
                        different when this option is enabled.

        PCI_INTR_FIXUP  Fixup PCI interrupt routing via PCIBIOS or ACPI.

                        Some i386 and amd64 BIOS implementations don't assign
                        an interrupt for some devices.

                        This option assigns an interrupt for such devices
                        instead of relying upon the BIOS to do so.

                        If a valid interrupt has already been assigned to a
                        device, this option leaves the interrupt as is.

HARDWARE
     NetBSD includes machine-independent PCI drivers, sorted by device type
     and driver name:

   SCSI interfaces
           ahc(4)        Adaptec 29xx, 39xx, and other AIC-7xxx-based SCSI
                         interfaces.

           adv(4)        Advansys SCSI interfaces.

           adw(4)        Advansys Ultra Wide SCSI interfaces.

           bha(4)        Buslogic BT-9xx SCSI interfaces.

           dpt(4)        DPT SmartCache/SmartRAID III and IV SCSI interfaces.

           iha(4)        Initio INIC-940/950 SCSI interfaces.

           isp(4)        QLogic ISP-1020, ISP-1040, and ISP-2100 SCSI and
                         FibreChannel interfaces.

           mfi(4)        LSI Logic & Dell MegaRAID SAS RAID controllers.

           mly(4)        Mylex AcceleRAID and eXtremeRAID controllers with v6
                         firmware.

           mpii(4)       LSI Logic Fusion-MPT Message Passing Interface II SAS
                         controllers.

           mpt(4)        LSI Logic Fusion-MPT SCSI/Fibre Channel/SAS
                         controllers.

           nca(4)        Domex 536 SCSI interfaces.

           pcscp(4)      Advanced Micro Devices Am53c974 PCscsi-PCI SCSI
                         interfaces.

           siop(4)       Symbios Logic/NCR 53c8xx-family SCSI interfaces.

           trm(4)        Tekram TRM-S1040 ASIC based SCSI interfaces.

   Storage controllers
           aac(4)        The Adaptec AAC family of RAID controllers.

           ahcisata(4)   AHCI 1.0 and 1.1 compliant SATA controllers.

           amr(4)        The AMI and LSI Logic MegaRAID family of RAID
                         controllers.

           arcmsr(4)     Areca Technology Corporation SATA/SAS RAID
                         controllers.

           cac(4)        Compaq array controllers.

           ciss(4)       HP/Compaq Smart ARRAY 5/6 RAID controllers.

           icp(4)        ICP Vortex GDT and Intel Storage RAID controllers.

           ixpide(4)     ATI Technologies IXP IDE controllers

           mlx(4)        Mylex DAC960 and DEC SWXCR RAID controllers.

           nside(4)      National Semiconductor PC87415 PCI-IDE controllers.

           nvme(4)       Non-Volatile Memory (NVM Express) host controllers.

           pdcsata(4)    Promise Serial-ATA disk controllers.

           pciide(4)     IDE disk controllers.

           rtsx(4)       Realtek SD card readers.

           svwsata(4)    Serverworks Serial ATA disk controllers.

           twa(4)        3ware Apache RAID controllers.

           twe(4)        3Ware Escalade RAID controllers.

           viaide(4)     AMD, NVIDIA and VIA IDE disk controllers.

   Wired network interfaces
           alc(4)        Atheros AR813x/AR815x/AR816x/AR817x and Killer
                         E2200/2400/2500 10/100/1000 Ethernet interfaces.

           ale(4)        Atheros AR8121/AR8113/AR8114 (Attansic L1E)
                         10/100/1000 Ethernet interfaces.

           aq(4)         Aquantia AQC multigigabit Ethernet interfaces.

           bge(4)        Broadcom BCM57xx/BCM590x 10/100/1000 Ethernet
                         interfaces.

           bnx(4)        Broadcom NetXtreme II 10/100/1000 Ethernet
                         interfaces.

           ena(4)        Elastic Network Adapter interfaces.

           ep(4)         3Com 3c590, 3c595, 3c900, and 3c905 Ethernet
                         interfaces.

           epic(4)       SMC83C170 (EPIC/100) Ethernet interfaces.

           et(4)         Agere/LSI ET1310/ET1301 10/100/1000 Ethernet
                         interfaces.

           ex(4)         3Com 3c900, 3c905, and 3c980 Ethernet interfaces.

           fxp(4)        Intel EtherExpress PRO 10+/100B Ethernet interfaces.

           gsip(4)       National Semiconductor DP83820 based Gigabit Ethernet
                         interfaces.

           hme(4)        Sun Microelectronics STP2002-STQ Ethernet interfaces.

           ixg(4)        Intel 82598EB, 82599, X540 and X550 10 Gigabit
                         Ethernet interfaces.

           ixl(4)        Intel 700 series Ethernet interfaces.

           jme(4)        JMicron Technologies JMC250/JMC260 Ethernet
                         interfaces.

           le(4)         PCNet-PCI Ethernet interfaces.  Note, the pcn(4)
                         driver supersedes this driver.

           lii(4)        Attansic/Atheros L2 Fast-Ethernet interfaces.

           mcx(4)        Mellanox 5th generation Ethernet devices.

           msk(4)        Marvell Yukon 2 based Gigabit Ethernet interfaces.

           ne(4)         NE2000-compatible Ethernet interfaces.

           nfe(4)        NVIDIA nForce Ethernet interfaces.

           ntwoc(4)      SDL Communications N2pci and WAN/ic 400 synchronous
                         serial interfaces.

           pcn(4)        AMD PCnet-PCI family of Ethernet interfaces.

           re(4)         Realtek 10/100/1000 Ethernet adapters.

           rge(4)        Realtek RTL8125-based Ethernet interfaces.

           rtk(4)        Realtek 8129/8139 based Ethernet interfaces.

           sf(4)         Adaptec AIC-6915 10/100 Ethernet interfaces.

           sip(4)        Silicon Integrated Systems SiS 900, SiS 7016, and
                         National Semiconductor DP83815 based Ethernet
                         interfaces.

           sk(4)         SysKonnect SK-98xx based Gigabit Ethernet interfaces.

           ste(4)        Sundance ST-201 10/100 based Ethernet interfaces.

           stge(4)       Sundance/Tamarack TC9021 based Gigabit Ethernet
                         interfaces.

           ti(4)         Alteon Networks Tigon I and Tigon II Gigabit Ethernet
                         driver.

           tl(4)         Texas Instruments ThunderLAN-based Ethernet
                         interfaces.

           tlp(4)        DECchip 21x4x and clone Ethernet interfaces.

           vge(4)        VIA Networking Technologies VT6122 PCI Gigabit
                         Ethernet adapter driver.

           vmx(4)        VMware VMXNET3 virtual Ethernet interfaces.

           vr(4)         VIA VT3043 (Rhine) and VT86C100A (Rhine-II) Ethernet
                         interfaces.

           wm(4)         Intel i8254x Gigabit Ethernet driver.

   Wireless network interfaces
           an(4)         Aironet 4500/4800 and Cisco 340 series 802.11
                         interfaces.

           atw(4)        ADMtek ADM8211 IEEE 802.11b PCI/CardBus wireless
                         network interaces.

           ath(4)        Atheros IEEE 802.11a/b/g wireless network interfaces.

           athn(4)       Atheros IEEE 802.11a/b/g/n wireless network
                         interfaces.

           bwi(4)        Broadcom BCM430x/4318 IEEE 802.11b/g wireless network
                         interfaces.

           bwfm(4)       Broadcom and Cypress FullMAC wireless network
                         interfaces.

           ipw(4)        Intel PRO/Wireless 2100 MiniPCI network interfaces.

           iwi(4)        Intel PRO/Wireless 2200BG and 2915ABG MiniPCI network
                         interfaces.

           iwm(4)        Intel Dual Band Wireless AC PCIe Mini Card network
                         interfaces.

           iwn(4)        Intel Wireless WiFi Link 4965/5000/1000 and Centrino
                         Wireless-N 1000/2000/6000 PCIe Mini network
                         interfaces.

           malo(4)       Marvell Libertas 88W8335/88W8310/88W8385 802.11b/g
                         wireless network interfaces.

           ral(4)        Ralink Technology RT2500/RT2600-based 802.11a/b/g
                         wireless network interfaces.

           rtw(4)        Realtek RTL8180L 802.11b wireless network interfaces.

           rtwn(4)       Realtek RTL8188CE/RTL8192CE 802.11b/g/n wireless
                         network interfaces.

           wi(4)         WaveLAN/IEEE and PRISM-II 802.11 wireless interfaces.

           wpi(4)        Intel PRO/Wireless 3945ABG Mini PCI Express network
                         adapters.

   Serial interfaces
           cy(4)         Cyclades Cyclom-4Y, -8Y, and -16Y multi-port serial
                         interfaces.

           cz(4)         Cyclades-Z series multi-port serial interfaces.

   Audio devices
           auacer(4)     Acer Labs M5455 I/O Controller Hub integrated AC'97
                         audio device.

           auich(4)      Intel I/O Controller Hub integrated AC'97 audio
                         device.

           auvia(4)      VIA VT82C686A integrated AC'97 audio device.

           autri(4)      Trident 4DWAVE-DX/NX, SiS 7018, ALi M5451 AC'97 audio
                         device.

           clcs(4)       Cirrus Logic CS4280 audio device.

           clct(4)       Cirrus Logic CS4281 audio device.

           cmpci(4)      C-Media CMI8x38 audio device.

           eap(4)        Ensoniq AudioPCI audio device.

           emuxki(4)     Creative Labs SBLive! and PCI 512 audio device.

           esa(4)        ESS Technology Allegro-1 / Maestro-3 audio device.

           esm(4)        ESS Maestro-1/2/2e PCI AC'97 Audio Accelerator audio
                         device.

           eso(4)        ESS Solo-1 PCI AudioDrive audio device.

           fms(4)        Forte Media FM801 audio device.

           hdaudio(4)    High Definition Audio Specification 1.0 device.

           neo(4)        NeoMagic MagicMedia 256 audio device.

           sv(4)         S3 SonicVibes audio device.

           yds(4)        Yamaha YMF724/740/744/754-based audio device.

   Bridges
           cbb(4)        PCI Yenta compatible CardBus bridges.

           pceb(4)       Generic PCI-EISA bridges; see eisa(4).

           pcib(4)       Generic PCI-ISA bridges; see isa(4).

           ppb(4)        Generic PCI bridges, including expansion backplanes.

   Miscellaneous devices
           bktr(4)       Brooktree 848 compatible TV cards.

           ehci(4)       USB EHCI host controllers.

           gtp(4)        Gemtek PCI FM radio devices.

           ibmcd(4)      IBM 4810 BSP cash drawer ports.

           iop(4)        I2O I/O processors.

           oboe(4)       Toshiba OBOE IrDA SIR/FIR controller.

           ohci(4)       USB OHCI host controllers.

           pcic(4)       PCMCIA controllers, including the Cirrus Logic
                         GD6729.

           puc(4)        PCI "universal" communications cards, containing
                         com(4) and lpt(4) communications ports.

           uhci(4)       USB UHCI host controllers.

           virtio(4)     Para-virtualized I/O in a virtual machine.

           vga(4)        VGA graphics boards.

           xhci(4)       USB XHCI host controllers.

SEE ALSO
     pci(3), agp(4), intro(4), pcictl(8), pci(9)

HISTORY
     The machine-independent PCI subsystem appeared in NetBSD 1.2.

NetBSD 10.99                     July 10, 2022                    NetBSD 10.99