Updated: 2022/Sep/29

Please read Privacy Policy. It's for your privacy.


IWN(4)                       Device Drivers Manual                      IWN(4)

NAME
     iwn - Intel WiFi Link and Centrino IEEE 802.11 wireless network driver

SYNOPSIS
     iwn* at pci? dev ? function ?

DESCRIPTION
     The iwn driver provides support for Intel Wireless WiFi Link
     4965/5000/1000 and Centrino Wireless-N 1000/2000/6000 Series PCIe Mini
     Card network adapters.

     The Intel Wireless WiFi Link 4965AGN (codenamed Kedron) is a PCIe Mini
     Card network adapter that operates in the 2GHz and 5GHz spectra.  It has
     2 transmit paths and 3 receiver paths (2T3R).  It is part of the fourth-
     generation Centrino platform (codenamed Santa Rosa).

     The Intel WiFi Link 5000 series is a family of wireless network adapters
     that operate in the 2GHz and 5GHz spectra.  They are part of the fifth-
     generation Centrino platform (codenamed Montevina).  These adapters are
     available in both PCIe Mini Card (model code ending by MMW) and PCIe Half
     Mini Card (model code ending by HMW) form factor.  The iwn driver
     provides support for the 5100 (codenamed Shirley Peak 1x2), 5150
     (codenamed Echo Peak-V), 5300 (codenamed Shirley Peak 3x3) and 5350
     (codenamed Echo Peak-P) adapters.  The 5100 and 5150 adapters have 1
     transmit path and 2 receiver paths (1T2R).  The 5300 and 5350 adapters
     have 3 transmit paths and 3 receiver paths (3T3R).

     The Intel WiFi Link 1000 (codenamed Condor Peak) is a single-chip
     wireless network adapter that operates in the 2GHz spectrum.  It is part
     of the sixth-generation Centrino platform (codenamed Calpella).  It is
     available in both PCIe Mini Card (model code ending by MMW) and PCIe Half
     Mini Card (model code ending by HMW) form factor.  It has 1 transmit path
     and 2 receiver paths (1T2R).

     The Intel Centrino Ultimate-N 6300 (codenamed Puma Peak 3x3) is a single-
     chip wireless network adapter that operates in the 2GHz and 5GHz spectra.
     It has 3 transmit paths and 3 receiver paths (3T3R).  The Intel Centrino
     Advanced-N 6250 (codenamed Kilmer Peak) is a combo WiFi/WiMAX network
     adapter that operates in the 2GHz and 5GHz spectra.  It has 2 transmit
     paths and 2 receiver paths (2T2R).  The Intel Centrino Advanced-N 6200
     (codenamed Puma Peak 2x2) is a wireless network adapter that operates in
     the 2GHz and 5GHz spectra.  It has 2 transmit paths and 2 receiver paths
     (2T2R).  These adapters are part of the sixth-generation Centrino
     platform (codenamed Calpella).

     The Intel Centrino Wireless-N 2230 (codename Jackson Peak) and Intel
     Centrino Wireless-N 2200 (codename Marble Peak) are wireless network
     adapters that operate in the 2GHz spectrum.  These adapters have 2
     transmit paths and 2 receiver paths (2T2R).  The Intel Centrino Wireless-
     N 135 and Intel Centrino Wireless-N 105 (codename Canyon Peak) also
     operate in the 2GHz spectrum.  These adapters have 1 transmit path and 1
     receiver path (1T1R).

     By default, the iwn driver configures the adapter for BSS operation (aka
     infrastructure mode).  This mode requires the use of an access point.

     For more information on configuring this device, see ifconfig(8).

CONFIGURATION
     The iwn driver can be configured at runtime with ifconfig(8) using the
     following parameters:

     bssid bssid
             Set the desired BSSID.

     -bssid  Unset the desired BSSID.  The interface will automatically select
             a BSSID in this mode, which is the default.

     chan n  Set the channel (radio frequency) to be used by the driver based
             on the given channel ID n.

     -chan   Unset the desired channel to be used by the driver.  The driver
             will automatically select a channel in this mode, which is the
             default.

     media media
             The iwn driver supports the following media types:

             autoselect  Enable autoselection of the media type and options.

     mediaopt opts
             The iwn driver supports the following media options:

             monitor  Select monitor mode.

     -mediaopt opts
             Disable the specified media options on the driver and return it
             to the default mode of operation (BSS).

     mode mode
             The iwn driver supports the following modes:

             11a  Force 802.11a operation.
             11b  Force 802.11b operation.
             11g  Force 802.11g operation.

     nwid id
             Set the network ID.  The id can either be any text string up to
             32 characters in length, or a series of hexadecimal digits up to
             64 digits.  An empty id string allows the interface to connect to
             any available access points.  By default the iwn driver uses an
             empty string.  Note that network ID is synonymous with Extended
             Service Set ID (ESSID).

     nwkey key
             Enable WEP encryption using the specified key.  The key can
             either be a string, a series of hexadecimal digits (preceded by
             `0x'), or a set of keys of the form "n:k1,k2,k3,k4", where `n'
             specifies which of the keys will be used for transmitted packets,
             and the four keys, "k1" through "k4", are configured as WEP keys.
             If a set of keys is specified, a comma (`,') within the key must
             be escaped with a backslash.  Note that if multiple keys are
             used, their order must be the same within the network.  iwn is
             capable of using both 40-bit (5 characters or 10 hexadecimal
             digits) or 104-bit (13 characters or 26 hexadecimal digits) keys.

     -nwkey  Disable WEP encryption.  This is the default mode of operation.

EXAMPLES
     The following ifconfig.if(5), example configures iwn0 to join whatever
     network is available on boot, using WEP key "0x1deadbeef1", channel 11,
     obtaining an IP address using DHCP:

           dhcp NONE NONE NONE nwkey 0x1deadbeef1 chan 11

     Configure iwn0 for WEP, using hex key "0x1deadbeef1":

           # ifconfig iwn0 nwkey 0x1deadbeef1

     Return iwn0 to its default settings:

           # ifconfig iwn0 -bssid -chan media autoselect \
                   nwid "" -nwkey

     Join an existing BSS network, "my_net":

           # ifconfig iwn0 192.168.1.1 netmask 0xffffff00 nwid my_net

DIAGNOSTICS
     iwn%d: device timeout  A frame dispatched to the hardware for
     transmission did not complete in time.  The driver will reset the
     hardware.  This should not happen.

     iwn%d: fatal firmware error  For some reason, the firmware crashed.  The
     driver will reset the hardware.  This should not happen.

     iwn%d: radio is disabled by hardware switch  The radio transmitter is off
     and thus no packet can go out.  The driver will reset the hardware.  Make
     sure the laptop radio switch is on.

     iwn%d: error %d, could not read firmware %s  For some reason, the driver
     was unable to read the firmware image from the filesystem.  The file
     might be missing or corrupted.

     iwn%d: could not get firmware handle %s
     iwn%d: could not read firmware  The driver was unable to find the file
     with the proper firmware image.  It should be located in
     /libdata/firmware/if_iwn.

     iwn%d: firmware file too short: %d bytes  The firmware image is corrupted
     and can't be loaded into the adapter.

     iwn%d: could not load firmware  An attempt to load the firmware into the
     adapter failed.  The driver will reset the hardware.

SEE ALSO
     arp(4), ifmedia(4), intro(4), netintro(4), pci(4), ifconfig.if(5),
     ifconfig(8)

AUTHORS
     The iwn driver and this man page were written by Damien Bergamini
     <damien.bergamini@free.fr>.

NetBSD 10.99                   October 30, 2014                   NetBSD 10.99