I would appreciate any donations. Wishlist or send e-mail type donations to maekawa AT daemon-systems.org.
VIRTIO(4) Device Drivers Manual VIRTIO(4) NAME virtio - Para-virtualized I/O in a virtual machine SYNOPSIS virtio* at pci? dev ? function ? ld* at virtio? vioif* at virtio? viomb* at virtio? viornd* at virtio? vioscsi* at virtio? DESCRIPTION virtio defines an interface for efficient, standard and extensible I/O between the hypervisor and the virtual machine. The virtio device driver represents an emulated PCI device that the hypervisor makes available to the virtual machine. virtio driver itself provides the core infrastructure to communicate with the hypervisor (called virtqueues) and supports the following devices: ld(4) A Disk device. vioif(4) An Ethernet device. viomb(4) A pseudo-device to release memory back to the hypervisor. viornd(4) An entropy source. vioscsi(4) A SCSI adapter. SEE ALSO ld(4), pci(4), vioif(4), viomb(4), viornd(4), vioscsi(4) Rusty Russell, IBM Corporation, Virtio PCI Card Specification, http://ozlabs.org/~rusty/virtio-spec/. HISTORY The virtio driver first appeared in NetBSD 6.0. NetBSD 8.0 May 17, 2017 NetBSD 8.0