I would appreciate any donations. Wishlist or send e-mail type donations to maekawa AT daemon-systems.org.
DPT(4) Kernel Interfaces Manual DPT(4) NAME dpt -- DPT EATA SCSI adapter driver SYNOPSIS dpt* at isa? port ? irq ? dma ? dpt* at eisa? slot ? dpt* at pci? dev ? function ? scsibus* at dpt? DESCRIPTION The dpt driver provides support for third and fourth generation DPT SCSI controllers. All communication with the controllers is conducted via the EATA (Enhanced AT Bus Attachment) protocol. DPT adapters examine and interpret all SCSI commands received before passing them to any underlying physical device(s). In this way, caching, RAID and other transformations are achieved while remaining transparent to the host operating system. HARDWARE The dpt driver provides support for the adapters listed below. Later models are supported by the iop driver. DPT SmartCache III DPT SmartCache IV DPT SmartRAID III DPT SmartRAID IV FILES /dev/dptu control device for unit u DIAGNOSTICS None of these messages should be encountered under normal circumstances. It should be noted that the list below is not complete. dpt%d: readcfg failed - see dpt(4) The EATA configuration data did not appear upon request. This may be caused by older firmware. Generally the solution is to power-cycle the affected machine. dpt%d: spurious intr A spurious interrupt was received from the HBA. dpt%d: bogus status (returned CCB id NNNN) A corrupt or incomplete status packet was received from the HBA. SEE ALSO cd(4), ch(4), dpti(4), intro(4), iop(4), scsi(4), sd(4), st(4) The sysutils/dptutil package. CAM committee standard CAM/89-004 - the EATA (Enhanced AT Bus Attachment) protocol. HISTORY The dpt driver first appeared in NetBSD 1.4.2. BUGS EATA adapters other than listed may function correctly with the dpt driver, however a definitive list is not available. Older boards that do not support scatter-gather I/O or DMA are not supported. ECC formatted disk and arrays (i.e. with a sector size of 528 bytes) do not work correctly with the PM2041 and certain firmware revisions of the PM3334. NetBSD 7.1.2 December 7, 2002 NetBSD 7.1.2