I would appreciate any donations. Wishlist or send e-mail type donations to maekawa AT daemon-systems.org.
MALO(4) Kernel Interfaces Manual MALO(4) NAME malo -- Marvell Libertas IEEE 802.11b/g wireless network device SYNOPSIS malo* at pci? DESCRIPTION The malo driver provides support for Marvell Libertas 88W8335/88W8310/88W8385 based PCI network adapters. The second generation 88W8335/88W8310 chipsets support 802.11b/g. These are the modes the malo driver can operate in: BSS mode Also known as infrastructure mode, this is used when associating with an access point, through which all traffic passes. This mode is the default. monitor mode In this mode the driver is able to receive packets without associating with an access point. This disables the internal receive filter and enables the card to capture packets from networks which it wouldn't normally have access to, or to scan for access points. The malo driver can be configured to use Wired Equivalent Privacy (WEP) or Wi-Fi Protected Access (WPA-PSK and WPA2-PSK). WPA is the de facto encryption standard for wireless networks. It is strongly recommended that WEP not be used as the sole mechanism to secure wireless communication, due to serious weaknesses in it. The malo driver relies on the software 802.11 stack for both encryption and decryption of data frames. The malo driver can be configured at runtime with ifconfig(8) or on boot with ifconfig.if(5). FILES The driver needs a set of firmware files which are loaded when an interface is brought up: /libdata/firmware/malo/malo8335-h /libdata/firmware/malo/malo8335-m /libdata/firmware/malo/malo8338 /libdata/firmware/malo/malo8385-h /libdata/firmware/malo/malo8385-m These firmware files are not free because Marvell refuses to grant distribution rights. As a result, even though OpenBSD includes the driver, the firmware files cannot be included and users have to download these files on their own. A prepackaged version of the firmware, designed to be used with pkg_add(1), can be found at: http://www.nazgul.ch/malo/malo-firmware-1.4.tgz HARDWARE The following cards are among those supported by the malo driver: Card Chip Bus Standard Netgear WG311v3 88W8335 PCI b/g Tenda TWL542P 88W8335 PCI b/g EXAMPLES The following ifconfig.if(5) example configures malo0 to join whatever network is available on boot, using WEP key ``0x1deadbeef1'', channel 11, obtaining an IP address using DHCP: dhcp NONE NONE NONE nwkey 0x1deadbeef1 chan 11 Join an existing BSS network, ``my_net'': # ifconfig malo0 192.168.1.1 netmask 0xffffff00 nwid my_net NOTES Contrary to the driver on OpenBSD , this driver currently does not work on PCMCIA/CARDBUS. SEE ALSO arp(4), ifmedia(4), intro(4), netintro(4), pci(4), ifconfig.if(5), hostapd(8), ifconfig(8) AUTHORS The malo driver was first written by Claudio Jeker <email@example.com> and Marcus Glocker <firstname.lastname@example.org> and appeared first in OpenBSD 4.1. NetBSD porting was done by Arnaud Degroote <degroote@NetBSD.org>. NetBSD 7.1.2 July 30, 2012 NetBSD 7.1.2