I would appreciate any donations. Wishlist or send e-mail type donations to maekawa AT daemon-systems.org.
SIOP(4) Kernel Interfaces Manual SIOP(4) NAME siop -- Symbios Logic/NCR 53c8xx SCSI driver SYNOPSIS hppa siop* at mainbus? irq 3 siop* at phatomas? irq 3 PCI siop* at pci? dev ? function ? options SIOP_SYMLED scsibus* at siop? DESCRIPTION The siop driver provides support for the Symbios Logic/NCR 53x8xx series of SCSI controller chips: - 53c810, 53c810a and 53c815 (Fast SCSI) - 53c820, 53c825 and 53c825a (Fast-Wide SCSI) - 53c860 (Ultra SCSI) - 53c875 and 53c875j (Ultra-Wide SCSI) - 53c876 (Dual Ultra-Wide SCSI) - 53c885 (Ultra-Wide SCSI and Ethernet) - 53c895 (Ultra2-Wide SCSI) - 53c896 (PCI 64bit, dual Ultra2-Wide SCSI) - 53c1010-33 (PCI 64bit, dual Ultra160 SCSI) - 53c1510d (PCI 64bit, dual Ultra2-wide SCSI) The SIOP_SYMLED option causes the driver to report SCSI activity on the GPIO pin 1, which is connected to the activity LED on some adapters. At this time only the 53c895 based Symbios and Tekram adapters are known to require this. If both siop and the esiop(4) drivers are compiled, esiop(4) will take precedence for controllers it supports. SEE ALSO cd(4), ch(4), esiop(4), intro(4), pci(4), scsi(4), sd(4), st(4), uk(4) HISTORY The siop driver first appeared in NetBSD 1.5. AUTHORS The siop driver was written by Manuel Bouyer <Manuel.Bouyer@lip6.fr> for NetBSD. BUGS siop supports the 53c1010-33 in Ultra2-wide mode only. Use esiop(4) for Ultra160 support. NetBSD 7.1.2 April 5, 2008 NetBSD 7.1.2