I would appreciate any donations. Wishlist or send e-mail type donations to maekawa AT daemon-systems.org.
FUJBP(4) Device Drivers Manual FUJBP(4) NAME fujbp, fujhk - Fujitsu Brightness, Pointer, and Hotkeys SYNOPSIS fujbp* at acpi? fujhk* at acpi? DESCRIPTION Some Fujitsu laptops come with vendor-specific ACPI devices to manage the laptop hotkeys (such as the `Eco' button), and to control various built- in components (such as the display, the touchpad, and the speakers). The fujbp and fujhk drivers provide support, through these ACPI devices, for hotkeys, backlight on/off switch, brightness level control, and pointer on/off switch. The following sysctl(8) read/write variables are provided (when hardware support is available): hw.acpi.fujbp0.brightness Brightness level (integer). hw.acpi.fujbp0.pointer Pointer switch state (boolean). hw.acpi.fujhk0.backlight Backlight switch state (boolean). Please note, however, that future versions of the drivers may remove these sysctl(8) variables without prior notice. SEE ALSO acpi(4), acpivga(4), sysctl(8), pmf(9), sysmon_pswitch(9) HISTORY The fujbp and fujhk drivers appeared in NetBSD 6.0. AUTHORS Gr'egoire Sutre <gsutre@NetBSD.org> CAVEATS Brightness level and backlight switch state should be controlled via wsconsctl(8) instead of sysctl(8). The sysctl(8) variable hw.acpi.fujbp0.pointer should be replaced by a platform-independent userland control. NetBSD 8.0 February 20, 2011 NetBSD 8.0