I would appreciate any donations. Wishlist or send e-mail type donations to maekawa AT daemon-systems.org.
GENFB(4) Device Drivers Manual GENFB(4) NAME genfb - generic framebuffer console driver SYNOPSIS genfb* at pci? genfb* at sbus? wsdisplay* at genfb? DESCRIPTION The genfb driver provides support for generic framebuffers that have no native driver. All it needs are some parameters to describe the framebuffer and an address. PCI When attaching to a pci(4) bus the driver is configured via device properties: width (uint32) Width in pixels. height (uint32) Height in pixels. stride (uint32) Line size in bytes. depth (uint32) Bits per pixel. is_console (bool) If true, genfb will try to become the system console. address (uint32) Bus address of the framebuffer. SBus When attaching to sbus(4) all those parameters are retrieved from the firmware. SEE ALSO pci(4), sbus(4), wscons(4), wsdisplay(4) BUGS There is no way to change the color map even when the firmware supports it. The pci(4) bus frontend has only been tested on macppc, i386, and amd64 and requires machine dependent code to pass the properties mentioned above. So far only macppc, i386, and amd64 provides them. NetBSD 8.99.34 August 23, 2009 NetBSD 8.99.34