I would appreciate any donations. Wishlist or send e-mail type donations to maekawa AT daemon-systems.org.
LOCATE.CONF(5) File Formats Manual LOCATE.CONF(5) NAME locate.conf -- locate database configuration file DESCRIPTION The locate.conf file specifies the behavior of locate.updatedb(8), which creates the locate(1) database. The locate.conf file contains a list of newline separated records, each of which is composed of a keyword and arguments, which are separated by white space. Arguments with embedded shell metacharacters must be quoted in sh(1) style. Lines beginning with ``#'' are treated as comments and ignored. However, a ``#'' in the middle of a line does not start a comment. The configuration options are as follows: ignore pattern ... Ignore files or directories. When building the database, do not descend into files or directories which match one of the specified patterns. The matched files or directories are not stored to the database. Default: Not specified. ignorecontents pattern ... Ignore contents of directories. When building the database, do not descend into files or directories which match one of the specified patterns. The matched files or directories themselves are stored to the database. Default: Not specified. ignorefs type ... Ignore file system by type, adding type to the default list. When building the database, do not descend into file systems which are of the specified type. The mount points are not stored to the database. If a ``!'' is prepended to type, the meaning is negated, that is, ignore file systems which do not have the type. As a special case, if ``none'' is specified for type, the ignorefs list is cleared and all file systems are traversed. type is used as an argument to find(1) -fstype. The sysctl(8) command can be used to find out the types of file systems that are available on the system: sysctl vfs.generic.fstypes Default: !local cd9660 fdesc kernfs procfs searchpath directory ... Specify base directories to be put in the database. Default: / workdir directory Specify the working directory of locate.updatedb, in which a temporary file is placed. The temporary file is a list of all files, and you should specify a directory that has enough space to hold it. Default: /tmp Refer to find(1) for the details of pattern (see -path expression) and type (see -fstype expression). FILES /etc/locate.conf The file locate.conf resides in /etc. SEE ALSO find(1), locate(1), locate.updatedb(8), sysctl(8) HISTORY The locate.conf file format first appeared in NetBSD 2.0. AUTHORS ITOH Yasufumi NetBSD 7.1.2 July 10, 2011 NetBSD 7.1.2