I would appreciate any donations. Wishlist or send e-mail type donations to maekawa AT daemon-systems.org.
ONEWIRE(4) Kernel Interfaces Manual ONEWIRE(4) NAME onewire -- 1-Wire bus SYNOPSIS onewire* at gpioow? option ONEWIREVERBOSE DESCRIPTION 1-Wire bus was originally developed by Dallas Semiconductor for connecting integrated circuits. It is commonly used for connecting devices such as electronic keys, EEPROMs, temperature sensors, real-time clocks, security chips, etc. The onewire driver provides a uniform programming interface layer between 1-Wire master controllers and various 1-Wire slave devices. Each 1-Wire master controller attaches a onewire framework; several slave devices can then be attached to the onewire bus. The driver supports plugging and unplugging slave devices on the fly. SUPPORTED MASTERS gpioow(4) 1-Wire bus bit-banging through GPIO pin SUPPORTED SLAVES owtemp(4) temperature family type device SEE ALSO intro(4) HISTORY The onewire driver first appeared in OpenBSD 4.0 and NetBSD 4.0. AUTHORS The onewire driver was written by Alexander Yurchenko <email@example.com> and ported to NetBSD by Jeff Rizzo <riz@NetBSD.org>. NetBSD 7.1.2 April 4, 2006 NetBSD 7.1.2