I would appreciate any donations. Wishlist or send e-mail type donations to maekawa AT daemon-systems.org.
DRM(4) Device Drivers Manual DRM(4) NAME drm - Direct Rendering Manager (DRI kernel support) SYNOPSIS i915drm* at drm? mach64drm* at drm? mgadrm* at drm? r128drm* at drm? radeondrm* at drm? savagedrm* at drm? sisdrm* at drm? tdfxdrm* at drm? options DRM_DEBUG options DRM_NO_AGP DESCRIPTION The Direct Rendering Manager is part of the Direct Rendering Infrastructure for supporting video acceleration (3d acceleration, mostly). The drm drivers provide support for the following chipsets: i915drm Intel i915, i945 mach64drm Mach64 (3D Rage Pro, Rage) mgadrm Matrox G00, G50 r128drm ATI Rage 128 radeondrm ATI Radeon savagedrm S3 Savage sisdrm SiS tdfxdrm 3dfx (Voodoo) viadrm VIA To make use of the driver, the kernel must include agp(4) (for some drivers, using options DRM_NO_AGP instead may be sufficient), X(7) must be compiled with DRI support, Mesa DRI drivers must be installed, the appropriate /dev/dri/card* device must exist, and DRI must be enabled in the X configuration file. X(7) provided with NetBSD and compiled from pkgsrc(7) do so automatically where supported. X(7) will attempt to create the device node automatically. To create the device node manually: mkdir -p /dev/dri mknod /dev/dri/card0 c 180 0 chgrp wheel /dev/dri/card0 chmod 0660 /dev/dri/card0 To enable DRI in the X configuration add the following to either xorg.conf for Xorg(1) or XF86Config for XFree86(1) : Section "Module" ... Load "dri" Load "dri2" Load "glx" EndSection ... Section "DRI" Group "wheel" Mode 0660 EndSection Debugging output can be enabled and disabled by setting the sysctl(8) node hw.dri.debug. Additional information can be obtained from the sysctl(8) nodes hw.dri, hw.dri.card0, hw.dri.card1, etc. SEE ALSO XFree86(1), Xorg(1), agp(4), XF86Config(5), xorg.conf(5), X(7), /usr/X11R/lib/X11/doc/README.DRI Direct Rendering Infrastructure: http://dri.freedesktop.org/ HISTORY DRM was first available for Linux. Subsequently Eric Anholt ported the DRM kernel modules to FreeBSD. Erik Reid adapted the FreeBSD DRM kernel modules to NetBSD. As DRM continued to develop the NetBSD support was neglected. Tonnerre Lombard got the DRM modules working again, but DRM development once again left the NetBSD support behind. Finally Yorick Hardy took the FreeBSD DRM source and managed to get it compiling and working again on NetBSD, thanks largely to the efforts of all those mentioned above. Subsequently Matthias Drochner improved the DRM file hierarchy for NetBSD and committed the DRM kernel drivers. Matthew Green cleaned up this port and merged a set of newer drivers, with Arto Huusko and FUKAUMI Naoki helping to get the latest Mesa port up to date. The drm drivers appeared in NetBSD 5.0. AUTHORS Eric Anholt, Terry Barnaby, Erdi Chen, Michel Daenzer, Leif Delgass, Frank C. Earl, Rickard E. Faith, Jose Fonseca, Nicolai Haehnle, Jeff Hartmann, Thomas Hellstrom, Gareth Hughes, Felix Kuehling, Sung-Ching Lin, Kevin E. Martin, Daryll Strauss, Keith Whitwell CAVEATS In case of errors, /dev/dri/card0 may be changed, make sure to recreate it in that case. options DRM_DEBUG can slow DRI down a lot; disable it once drm works. NetBSD 8.99.34 July 10, 2018 NetBSD 8.99.34